No LAN after ASUS notebook BIOS Chip repair using a programmer

I have an X202e, and while installing Windows 10 my UEFI BIOS got corrupted and system wouldn't POST.

Since I have sufficient knowledge to do the repair myself, I bought CH341A programmer, unsoldered the chip, programed it with a .bin file I found on another forum and I've managed to get it working again.

The problem is that I can't get my LAN card to work since it's not recognized by the system (not Win10 nor Ubuntu).

I guess it got something with me flashing a dump from another computer that is probably causing a conflict (incorrect MAC address or something).

I've tried using FD44 to read the data from my dump but file won't open. I've tried also opening the dump file that I've used to program the chip but I get the same message: "Error parsing BIOS data. $BOOTEFIS signature not found. Please open correct ASUS BIOS file."

What do you think is the problem.

Also, will importing the data from the original BIOS make my LAN card work again?

Thank you in advance.

P.S. I'm a complete noob when it comes to UEFI (only worked with BIOS-es before) so if there are things that I should read please share them as well.

P.P.S. Let me know if I should upload dump files

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment