Model: PowerShot SX700 HS (PC2091/PC2093/2047) Body No: 902053007176 Released: April 2014

6 Questions View all

How do I check whether my Wifi is working?

I used to have no trouble sending photos to my smartphone using the camera's wifi. Recently this hasn't been working, with the the camera never getting beyond 'Start dedicated app on target device'. I've updated the Canon Camera Connect app, installed it on other devices and reset the camera's wifi settings but nothing has worked. Any suggestions as to what would be wrong?

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Hi, Can you see the camera's WiFi name ( the nickname you registered in the camera's WiFi menu) in the list of available WiFi connections either on your phone or when using a PC or laptop with WiFi capability?

by

Add a comment

2 Answers

I have the same problem. if it gets that far it is connected to the WIFI, in fact I get that message yet the camera can send emails and connect via my phones WIFI use 4G to get to cloud account and update camera settings, the Android app just seems to be a piece of cr@p

Was this answer helpful?

Score 0
Add a comment

This a problem which Canon know about but does nothing to correct. Its generic across the range of Powershot compacts.

They now have new software which they recommend users install in place of the CameraWindows app. This is also buggy.

I have a HP Desktop PC running under win10. A ASUS Laptop running Win7Pro and a Microsoft 640 Smartphone. I cannot connect to any of these devices from the Canon SX60hs.

To prove that it is not my devices at fault I borrowed a Sony Cybershot and it installed properly

on all three of my devices!!

Canon Support are giving me the run around and not at all empathetic.

If you Google Canon Wi-Fi problems for the SX50 or the SX60 you will find that all around the World users are having problems with Canon.

The SX50and the SX60 are great camera's let down with non functioning Wi-Fi issues. I have an eight year old SX10is. This camera works as well as the new SX60. Why should I use the SX60 if I have to unplug the memory card or plug in [ not supplied ] a cable to the Desktop/Laptop. I certainly cannot do either with the smartphone and this is what I wanted to use for the camera controls using the CanonWindows app.

Canon are letting down customers/purchasers by advertising the Camera's as Wi-Fi!! when from all the complaints that I have read it is not working to specification! Canon have a problem! Its either firmware or a software problem and its time they did something about it. Software should be an easy fix, the firmware another issue.

Well that's my beef Sarah - good luck and let us all know how you progress

regards

Alan W

Was this answer helpful?

Score 0
Add a comment

Add your answer

Sarah will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 9

All Time: 182