Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

677 Questions View all

battery not charging, chatger's light stays green

Hello,

I have bought a new battery through IFixit and it worked fine for the first week,then i didn't use my macbook for 2 weeks. After that, i tried to charge it, but it won't.

Only turns on when the charger is conncted, there is a status bar message indicating:

condition: Replace now

battery is not charging.

I have tried to reset the SMC&PRAM and even take out the battery, but the problem still not solved.

-- MacBook Pro 13" Unibody Mid 2010

Please help!!!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Please tell us the story of what ws happening with the old battery.

by

old battery was expanding"swollen" unitl i couldn't even click the trackpad.

by

No answer!!!! am I only the one who's facing this problem ?

by

There's to enough clues to work with. What does it do when you try to boot? Any sounds, lights?

by

I don't see anything up normal while booting...

by

Add a comment

1 Answer

Most Helpful Answer

Hey there! When the charge cable stays green, it typically indicates that either the I/O board or the battery is having some issues (or the battery is fully charged, but that seems unlikely). If you've already tried making sure that the battery has a good connection and checking the pins of the connection are still all there, then I would make sure that your I/O board still has a good connection. Failing that, contact out customer service, and we'll see what we can do about replacing that battery for you.

Best of luck in your repair!

Was this answer helpful?

Score 2

Comments:

Thank you for your answer, the pins are still there and I don't know how to figure if the case is the battery or the I/O. What I am sure about, is that the battery was charging after I installed it. I was thinking that since the battery is new and I left the macbook without usage for 2 weeks, than that would be the case. I tried my charger with another macbook pro"my friend's macbook", and It was working fine.

Please guide me if i can do a test to figure out the case " battery or the I/O".

I have tried lots of online solutions with no luck ! please help

by

Add a comment

Add your answer

harysi will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 76