Repair guides and support for a wide range of small engines.

7 Questions View all

murray riding mower spark

cleaned fuel tank, new filter, hoses. new battery, starter works. selonoid good, sparkplug new. still can't get spark

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@jamesb what make and model engine does your murray mower have?

by

Briggs & Stratton model 28R707. put plug in wire and cranked engine with 3 separate plugs, no spark color. cleaned Armature, checked coil for continuity. Stator green horizontal mark on the right in front of Armature at start position. still no start.

by

checked fuse, it's good

by

Have you checked the stop switch? Try disconnecting it. Take it off the coil housing and reinstall blower housing, test for spark. If still no spark, it's most likely the coil.

by

Add a comment

1 Answer

Chosen Solution

Check gap of plug and regap if needed

Find where the wire off the spark plug housing and find where it goes. You can take a probe or wire tester and check for continuity... I use a multimeter, if the wire in the holder for the spark plug has no breaks in it... See what kind of igniter system it has.... Points, coil, whichever it might be, you can test the coil, or sand the points. Also check fuse if applicable for coil, see if it's bad. Some have a in line fuse.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Jamesb will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 84