Repair guides and support for LED, LCD, HD and other Vizio TVs.

224 Questions View all

Vizio logo comes on but no picture or sound

Yesterday 3/12 my vizio tv was working in the morning and when i went to turn it on in the evening only the vizio logo came on, no picture, no sound. Last Thursday 3/10 i had replaced my satellite with an antenna. Would the antenna install have anything to do with this issue.

thank you

ps my other 2 tvs work very good

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Given that the other TVs function correctly it is hard to imagine that an antenna installation was the cause of the problem with your Vizio TV

The firmware in your TV may have become corrupted, for whatever reason. Reloading the firmware for your TV may restore it back to normal.

Here is a link which I hope will help you to find the firmware for your Vizio model TV. Ensure that you get the firmware for your exact model as installing the wrong software can render the TV useless. Don't guess, look at the model information written on the sticker on the back of the TV.

https://support.vizio.com/s/

Here is a link which describes the procedure used to load the firmware into your TV.

http://www.viziofirmware.com/vizio_tv_fi...

It is a good sign that the logo is appearing as at least this proves that there is still life in the TV as the screen (and therefore the power supply) is functioning.

note: If you cannot find the firmware download for your particular model, contact Vizio support and ask if they have it and could they advise you where you can download it from or if it could be sent to you

Hopefully this is of some help.

Was this answer helpful?

Score 3
Add a comment

Add your answer

hondagoldwing1990 will be eternally grateful.
View Statistics:

Past 24 Hours: 24

Past 7 Days: 152

Past 30 Days: 672

All Time: 2,884