Sony A6000 is not working properly all of a sudden

Hi

I have an A6000 camera that suddenly is acting very strange. It will not allow me to make any adjustments in Apeture, Shuttter priority or Manual modes. Neither will it let me access the menu or even see pics already taken. I am at a loss at why this has happened as it has not been dropped or handled aggressively. I used it briefly on Monday and then on Tuesday evening the problems arose. I don't know what to do or where to go for help. I have been using your tutorials to learn how to use the camera so I decided to reach out for help. I have not down loaded any apps as I don't know how to do that nor have I updated any firmware. Oh I should mention in the auto mode like SCN or Intellegent plus it does take pictures although there is a slight delay or stickiness when shooting. I have been looking for a reset button to see if resetting would help but I have not been able to find one. So I am really at a loss on what to do next. (ps I live in Ghana so Incannot call Donys toll free number from here.

Keeping my fingers crossed you can help,

Karen

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

This question was migrated from http://meta.ifixit.com/Answers.

by

I have the same problem,I can access menu only right after changing mode, but nothing helped, I reinitialized camera, but nothing helped. I am sending it to Sony service...

by

Add a comment
Deck the Halls
With tools and Fix Kits

3 Answers

Hi there,

Try to press and hold down the Fn button for 5 seconds and look on the display ??

GrtZ,

Doka

Was this answer helpful?

Score 0
Add a comment

SOLVED!

I had this problem and scoured many forums. Suddenly all the dials became unresponsive while shooting. First noticed playback button didn't work.. then it did ...then it didn't, for good. The only responsive interface was the focus select (center of dial) and the c2, set as zoom to focus to dmf/mf settings.

Menu, Fn, AEL, Play, etc, were not responsive, ONLY in shooting mode. The shooting mode dial was sometimes responsive, and EVERYTHING worked in menu mode (which was accessible when usb connected, or by jamming the menu button in the preview seconds after taking a shot)

A number of other forum threads hinted that the problem was the camera getting stuck in 'half shutter' press. The physical button was not stuck, but the camera was tricked into thinking it was in half-press mode, wherein it was only focusing and none of the other feature settings are available.

Some other replies noted some improvements with wd40 in the shutter button mechanism (WOULD NOT SUGGEST), but hinted that the switch maybe the culprit.

A local repair shop gave an estimate of $565 CAD to replace the "circuit power circuit board", sounded suspect so I took my chances DIY'ing it with a precision phillips head and a spudger.

THE FIX

Camera was off warranty so I gave a go at a proper diagnosis.

ifixit has a guide to remove the back and top panel on the sony a6000, very simple, just keep track of your screws as they are not all the same size. Once the top panel is removed it was clear that there is an excess of lithium grease on the switch mechanism, it's possible some excess has migrated into the actual switch on the pcb causing the issue. Essentially, the pcb switch is contacting in a way it believes the camera is in half-press mode when it's not.

With isopropyl and a cue tip, I carefully dropped some cleaner in an around the pcb switch. Just enough cleaner to permeate the mechanism but not to drip about the pcb. Quickly wiping any excess, I let it to dry for about 5min. I click assembled the panels (without screwing), put the battery in and tested, immediately 80% improvement.

Prior there was 0 response from rear panel buttons, now I could clearly see that it was 'sticking'. I could shoot and the buttons functioned normally most of the time, with some 'sticking' prevalent which was often remedied by lightly tapping the shutter button to jog it fully open again.

I made a second pass with alcohol, cleaning and letting it to dry another 10min before re-assembling the device completely.

I've shot for a few minutes without 0 of the issue. Expect that it might pop up again but I know how to quickly repair it now. I removed some of the excess grease as well around the shutter / on/off mechanism, in case that was potentially the cause of the short in the switch.

One caution in opening the ilce-6000 was a smaller foam o-ring around what appeared to be the camera mic (located under the right side of the hot shoe when front facing) was difficult to replace as the adhesive had dried. I've left it out for now but seldom do video recording so don't expect any noticeable effect.

If you've found unresponsive of or sudden failure of the controls in shooting mode in your sony a6000 , a6300 , or NEX camera, I hope you find this guide and give a shot at repairs. It was very simple and saved me hundreds!

Was this answer helpful?

Score 0
Add a comment

Just wanted to come to this post and share what happened with me. I had the "half stuck" shutter problem, and not wanting to lose my camera for three weeks AND spend hundreds of dollars, I tried the contact cleaner from WD-40 for $16 on Amazon.

The first try fixed it for about 100 shots. Noting that there was an improvement, I tried again. This time, I'm past about 200 shots and it's working perfectly.

How I did it--take out the battery and memory card, spray the CONTACT CLEANER (not regular WD-40) into the little gap where you can get a liquid into the shutter button. I sprayed more than you would think, but not enough that it would be like pouring a liquid into the phone. I then pushed the button continuously to try to loosen up any dirt in the button. The first time worked a little bit (I thought it worked perfectly until the problem came back at about 100 shots and several lenses). The second time I did a little more and it's been just like new ever since (about 200 shots or more since then). I'll continue to post updates, but having seen this thread and trying the contact cleaner . . . I have to say try this first. It certainly didn't harm the camera and it was a lot cheaper than fixing it. It must be some grease or dust that got into the electronic connection. WAY better than sending it in for $200+ repair.

Of course, it could come back--and then I can still choose to send it in, but to fix the whole problem (for now) for $16 + 2-day prime shipping . . . and it's day and night between the spray and before, so I'm not seeing that it could be a bigger problem than the button connection itself, regardless of a repair company saying they need to replace the motherboard. All this, and I didn't even open one screw on the camera.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Karen will be eternally grateful.
View Statistics:

Past 24 Hours: 18

Past 7 Days: 93

Past 30 Days: 419

All Time: 2,164