Released on June 23, 1996, Model NUS-001, 64-bit gaming console

43 Questions View all

No video- not cable or connections.

So, not the common (cable) video issue with an NTSC version-

With all my games I have audio, but no video. The TV screen will go black when the unit is powered on and I get the audio from the game booting up. I know the cable is fine because it works on my buddy's Game Cube.

I've opened the unit up and used a point file (didn't have any isopropyl laying around at the time) on all the contacts- expansion pack, game slot, power connector and a/v connector. Also done the same with the contacts on the expansion pack and a few of the games.

just kinda wondering what my next steps are...

Answered! View the answer I have this problem too

Is this a good question?

Score 4
Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

3 Answers

Chosen Solution

You can try a stepwise protocol, its worked for me in the past for reasons unknown. First, take everything out: controllers, game, and jumper/expansion pack. Power it on for about 10 seconds and turn off. Add the jumper/expansion and turn on for about 10 seconds. Then add the game and power on for 10 seconds, then try to actually play something. For some reason its worked for me in the past, but I had both video and audio issues. Worth a shot.

Was this answer helpful?

Score 4


I was having the same problem... BWest you saved me!


This worked for me too. I had no signal whatsoever, performed these steps and it worked perfectly. Thank you so much BWest.


I had the same issue and your solution fixed it. Amazing. Thanks


Add a comment

This worked for me as well..Thank you for the post..!!

Was this answer helpful?

Score 1
Add a comment

I had a weird black+white only issue and this fixed it! Thank you!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Wombler will be eternally grateful.
View Statistics:

Past 24 Hours: 12

Past 7 Days: 92

Past 30 Days: 407

All Time: 11,012