Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor

132 Questions View all

iMac runs slow and fan running fast after replacing display

Any ideas on what might be causing my iMac to run slow and fan to be running fast after replacing the display. The display works fine and when I put the old one back in, the iMac runs normally.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Sounds like you forgot to reconnect one of the sensors or damaged it. Install this app so you can see what sensor is failing: TG Pro. Paste a screenshot of the console window into your question so we can see.

Was this answer helpful?

Score 4

Comments:

Hi Dan - You are correct. When replacing the display I forgot to remove the temperature sensor from the old display and install on the new one. Once I did that, it works perfectly.

Thanks!

by

Happy it all worked out!

by

Please remember to mark the answer as accepted.

by

Hi, where was the sensor located? Is it easy to transplant?

by

Add a comment

Hi, is there a way to trick the iMac to "think" it is connected with the LCD?

I am thinking to use the hardware without the display panel. However, my iMac is very slow and the fan is at this full speed when the display panel is not there.

Thank you !

Was this answer helpful?

Score 0

Comments:

Sorry not really, you see the design of the system requires the display as its part of the heat management system. Between the physical placement to prevent air from entering and its own thermal sensor you need it.

Besides, it looks funky without it ;-}

by

Really? =( I am kind of a DIY guy. I was thinking to cover it with an acrylic sheet,

remove the stand and mount it somewhere. I think it is cool. LOL

by

Add a comment

Add your answer

dcdet2000 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 17

All Time: 225