Why has the sound suddenly stopped?

Block Image

Hello, I wonder if you have any ideas? Whilst playing my digital radio on full volume, the sound suddenly stopped. Everything else still works: all lights, LCD display, channel selection, tuning, just absolutely no sound. When it happened, the sound was slightly distorted and then just disappeared instantly and has stayed away. The radio is meant to be of reasonable quality and is only about 18 months old. Any pointers would be greatly received. I am however, a complete novice, but happy to start learning and experimenting. If I make things worse then so be it. At least I will have given it a go. Many thanks :)

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

Bonkers - My revival Bluetune stopped producing sound. Literally ONE STAB of a headphone jack into the headphone socket on the top and it came back to life - BONZA!!!!

by

Problem: No sound, no display, but red "Mains" light on.

See my solution at http://ahamm.co.uk/roberts-radio-rd-3_FM...

by

Exactly the same thing happened to mine. Phoned Roberts tech support; they wanted to charge me £40 to take it away and repair it. Just tried your little trick and it's much improved. The volume was very low on the right channel through the headphones. Probably need to spray some switch cleaner in there. Thanks again!

by

I have the same problem; tried the jack stab in both ports many times, to no avail - although the line out works fine. Would rather not have to listen to this radio forever through secondary speakers. Is this an amp issue? (Phoned the Roberts' servicing line but was told that the model is now obsolete so they won't repair it.)

by

almondo - see my blog at: http://ahamm.co.uk/roberts-radio-rd-3_FM...

My problem was the 20mm fuse to the power amplifier.

by

Show 2 more comments

Add a comment

5 Answers

Chosen Solution

Does the headphone socket still work? (plug in a known good pair of headphones and try)

If the answer is yes, try plugging in and unplugging the headphones briskly, a few times.

The speaker might start working again.

The explanation: when you plug in a pair of headphones, the speakers will be muted by a switch contact on the headphone socket. Sometimes, especially when you don't normally use the headphone socket, this switch will corrode slightly just because it doesn't get any exercise, and the speakers will be muted even when no headphones are connected.

On the other hand, if the headphone socket doesn't work either, it is possible that the audio output amp has failed. You might be able to get this repaired under warranty, depending on where you're located - in Europe for example, electronic gadgets have a mandatory 2 year warranty.

Was this answer helpful?

Score 2

Comments:

Good tip, but no sound to headphones either nor to speakers after plugging headphones on and out of socket about 20 times. Seems like it might be the amp then. Any ideas how I would test that myself and what I may have to do to fix it if it is the amp? Many thanks.

by

Regrettably, my trusty search engine can't find any schematics or service docs for your radio, so I do not have the info to walk you a troubleshooting procedure. What you'd want to do, is figure out which of the components is the amp, see whether it's alive or not, and replace it if it indeed turns out to be dead.

However, you're most likely going to need:

* Some troubleshooting skills

* Suitable tools and at the very least a decent multimeter and better still, a 'scope

* A SMD-capable soldering iron and the skill to use it.

This is not really novice territory, and you might want to try your hand on some simple repairs first.

by

Thanks very much for all the time you have invested. I better admit defeat :)

by

Just remember that your radio might still be in warranty, so you might have it fixed at no charge.

It's not as instructive as tinkering, but still, it might be a solution.

by

Worked a treat for me re headphones tip. Thx so much. Sam

by

Show 2 more comments

Add a comment

I have my Robert Stream 63i lost its sound as well. Re-setting did not work, plugging /unplugging headphones either.

Everything works (I could hear it through the speakerphones), just no sound through the speakers themselves. It is such a shame as the Roberts system just came off the warranty. Quite disappointed really.

Was this answer helpful?

Score 0

Comments:

I have the same problem. No sound but the headphone works! I guestvi will use it when falling asleep.. my type is Roberts ecologic3. Quite disappointed . I believed the radio would last longer as it was quite expensive.

by

Add a comment

I have a small dab radio from Sainsbury's . Same things happened. Don't know where receipt is , I will have to just listen through the head phones I guess

Was this answer helpful?

Score 0

Comments:

I just banged radio on the work top . Bingo it's working x

by

Add a comment

What is the life expectancy of Roberts dab radio? I have ecologic3.

I had a non dab radio for over 10 years and it kept working well.

The dab Roberts is ill after 3 years of service. No sound though the headphones work. Very disappointed.

Was this answer helpful?

Score 0
Add a comment

I have an MP sound 43, not used it for ages, However, plugged everything came up OK, next morning it was as dead as a doornail.

Tried several things, finding out the input transformer was giving no output (5v dc 2.5 amp), Could not source one, so modified an off the shelf item.

Next, no sound, everything else worked. I had a spare speaker, tried that in the headphone socket, nothing, then the auxiliary socket, this worked fine but volume was fixed at about 6.

So now I'm on to the next lap, when I feel up to having another bash at it, at least it's working. (radio and CD)

Was this answer helpful?

Score 0

Comments:

I have tried to insert the earphones severall on my LG Model 3CD Changer as per the idea I got @http://ahamm.co.uk/roberts-radio-rd-.3_F...... The Sound came back after three insertions but it was dead again in about 10 minutes. I wonder what might be the problem

by

Add a comment

Add your answer

Sulis will be eternally grateful.
View Statistics:

Past 24 Hours: 46

Past 7 Days: 293

Past 30 Days: 1,346

All Time: 21,392