Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

567 Questions View all

MacBook Pro Will No Longer Recognise OSX.

Good day all,

This is my first post here so i'll try to make it simple.

I have a Macbook Pro, 4GB, Unibody, 13" 2.3GHZ, Early 2011, i5, (previously running El Capitan) with a 500GB HD (partitioned with 60GB for Windows Bootcamp).

Just before Christmas I experienced a fault. The wheel of death started to spin, and continued to do so for 11 minutes.

I manually shut down the machine, and rebooted it. However, upon reboot I noticed a prohibitory sign and a question mark with a folder.

I decided to boot into safe mode Command + R to restart the machine. I was unable to get to the desktop. It was suggested by various forums to download a fresh install of OSX.

The download would start normally, and complete successfully. However I could not boot it up to the desktop and the loading bar below the grey Apple logo would get half way, or with seconds remaining and stay that way for 5 hours +.

I was then advised to erase the HD and do a fresh install of OSX, so I preceded with that. Although I deleted/erased the MAC HD, I left the Windows partition there

I took the Mac to a computer repair store to get some technical help. Unfortunately the technician had never owned or serviced a Mac but spoke and shared from a PC perspective. It was suggested to change the start up disk and boot from Windows.

After that point, everything went down hill from there. I could no longer see ANYTHING Apple.

All I would hear was the chime, followed by a white blank screen, followed by a black screen with white text and the words reading:

No bootable device found--please insert and press any key.

Unfortunately, no key would work or respond. Not even the green LED on the caps-lock button.

I've tried various command prompts (as in the links provided) Command Prompt to no avail.

I then ran an experiment and inserted a 2.5" hard drive with Ubuntu Linux OS and the MBP booted and recognised it. I was able to open and close applications and so forth.

I then installed a Windows 7 HD and it recognised the OS but would not boot to the desktop. I could only access the options for Safe mode, Start Windows Normally, Recovery mode etc etc. However, no matter the option I selected it would just switch itself off and reboot with the chime.

I then installed a Seagate HD into the MBP with a fresh install of OSX Mavericks. No joy. White screen and error: No bootable device. I repeated this again with a Hitachi HD with a fresh install of OSX El Cap, but no joy. Again, the white screen and error code as above.

I've tried unplugging various components such as, Optical drive / Ram/ Airport, Battery/ Eject/ Trackpad etc etc and no change at all.

Again I install the Ubuntu HD and the MBP boots up.

I thought the fault was the HD Data cable, but Ubuntu booting up rules that out. I thought it was a HD failure, but I connected the previous HD externally via Sata & USB into a MBA (Mac Book Air) and that was successful. I could read all files and boot from that drive whilst holding the alt/option key.

It appears if the MBP is in a Bootcamp / OSX Coma and won't accept those operating systems (OSX or Windows).

If anybody has a suggestion, i'd be pleased to hear it. A little voice tells me it could be the Logic board. Or simply a Nvida chip that needs replacing...

It's been around 5 weeks now, and I'm missing my dearest April (Macbook Pro),

Thank you for reading :-)

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Sorry you have suffered and spent so much effort. Change the Hard Drive IR/ cable. Use a NEW one from a 2012 13" model. I know this sounds simplistic after what you have been through but I replace them all the time. It gets damaged as it comes over the last step by the bottom hitting it. I usually put pads on either side of the cable to prevent this when replacing. MacBook Pro 13" Unibody Early 2011 Hard Drive Cable Replacement

Was this answer helpful?

Score 5

Comments:

@mayer Thank you for the prompt response. An interesting theory, and one I should try indeed. Hopefully It would resolve the problem. Although it doesn't make sense why the MBP refuses to recognise OSX & Windows but happily boots up the Ubuntu/Linux HD. I have thought about obtaining another Logic Board, or going to a Genius Bar, but those are the last resort really.

by

To test my hypothesis, disconnect the hard drive cable from the logic board and boot from an external device.

by

@mayer I've tested your hypothesis as required. I Connected an external (Bootable) drive with the fresh install of OSX and allowed a natural boot up. I then rebooted the MBP whilst holding down the options/alt key. I then rebooted the device whilst holding down cmd (command) + R. After each attempt, I was displayed the same result. A white screen followed by "No bootable device found, please insert disk and press any key.

The only way that this machine has successfully booted is via the Ubuntu/Linux hard drive (installed inside the unit).

I wonder if the MBP has an internal memory/brain which keeps it in the coma. It seems to remember the last crash, and has never progressed past that since. It almost needs to be wiped or flushed to allow OSX to join again in harmony...

The new Logic Board is a last resort, but an option to be considered...

by

Did you try holding the option key to get to the boot manager and then selecting your external drive?

by

If it boots up cleanly with an external OS-X bootable drive, that points to an internal drive issue. Most often the SATA cable is damaged which can cause some odd boot up issues as you've encountered here. It's the first thing I replace when I get a system with drive issues.

by

Show 24 more comments

Add a comment

Add your answer

Lee Walker will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 9

All Time: 453