Launched in spring of 2014, the OnePlus One packs a 5.5" display and runs the Android-based CyanogenMod 12S operating system.

114 Questions View all

No Service after replacing digitizer

I just finished replacing my digitizer and i put my SIM in to find I get No Service, is there any fix for this?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

5 Answers

Did you reconnect the antenna behind motherboard?

Was this answer helpful?

Score 0
Add a comment

Hi, I have the same problem. I reconnected the antenna (positioned along the battery on right side - from backview). It did not help. Is there any other antenna in OPO? Thanks.

Was this answer helpful?

Score 0
Add a comment

There is a rectangular chip (seen here: https://d3nevzfk7ii3be.cloudfront.net/ig...) that I accidentally put in upside down that caused this same issue. Try rotating it 180 degrees.

Was this answer helpful?

Score 0
Add a comment

Hi dmpower54, thank you very much for your reply. My earpiece speaker was in the right position (I could not rotate it because of two pins with different width along the sides). So I am still with no service. Nevertheless, thank you again.

Was this answer helpful?

Score 0
Add a comment

Hi!

I have the same problem. Wifi working, sim detected and everything else is working but no cellular data.

Things I have tried:

1. Re-did all connections

2. Checked the gold pins are touching the metal plating on the back cover

3. Triple checked the Antenna cable was securely connected

4. Checked the earpiece speaker orientation (Can only go in one position)

Going to swap parts from another OPO to see what is the culprit...

Does anyone know which parts could cause this problem? Which gold pin is for cellular signal?

Was this answer helpful?

Score 0
Add a comment

Add your answer

John Smith will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 537