Repair guides and support for phones manufactured by BLU Products.

1350 Questions View all

will not boot or allow a factory reset

I just purchased this BLU Studio 5.5 C (D690U) phone less than a month ago. I had it charging on a wall charger and when I went to take the phone off charge, it was shut off. I held in the power button and it just shows up with the intro screen of

"BLU BOLD LIKE US" and stays on that screen. I pulled the battery and tried again, nothing once again. Its just stuck on that screen. I tried doing a factory reset on the phone but when I go into the recovery menu and select wipe data/factory reset, the only thing that comes up is a android guy with his chest open with a red triangle and a exclamation mark. Below the android guy it says "No command." Everything I select and try within the recovery menu, it just prompts me to the same screen of the android guy with the red triangle and the exclamation mark, with "No command." If anyone has any answers to this problem, please help me because if not, then I may try to go threw a Manufacturing Warranty with the company and try to get the same phone again, but I don't want to chance getting a refurbished phone.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

blu phones suck get a new one i have the same problem with my blu studio M HD and no one can fix it because the blu company wont give people the firmware to fix the phone $130 in the trash it sucks but youre better off with a galexy or iphone never buy a blu

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eric will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 8

Past 30 Days: 59

All Time: 626