Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

763 Questions View all

Problems with SSD after replacing cable

I had a SSD in my MacBook Pro 13'' mid 2012 working for some time, and one day it did not boot anymore, I tried reinstalling the system, recovering from Time Machine, pulling it out and reinstalling OS X on it through a USB case, all to no success.

I checked the SmartStatus with DriveDx (through another computer) and it had a huge count of UDMA Errors. I replaced the drive with a HDD and it worked, so I thought that maybe the SSD's controller went kaput (sent it back to the manufacturer, did not receive any news yet). I bought another SSD (brand new) put it in the MacBook, installed the system and as soon as I booted, started having freezing beach balls all the time. I ran BlackMagic Disk Speed Test and Read/Writes were around 120MB/s, way below what was expected.

Put the old HDD back, the computer worked OK, so I thought it was the cable that was damaged, not supporting higher speeds (strange thing is that the old SSD would not install or copy anything onto it).

Ordered a new cable, put it in, and here is where things get messy. With the HDD, no problem whatsoever. With the SSD, BlackMagic runs at 480MB/s (expected), but after some time, It starts freezing, I/O error counts sky rocket and if I shut it down and restart, I either get the question mark or the prohibit sign. If I wait long enough, it boots, so it seems that the problem is temperature related.

Any clues? Do I still have a faulty cable? Any help or insight is welcome.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

I replaced the hard drive cable again. Seems that the one that I ordered and replaced was also faulty...

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

You have me scratching my head a bit here.

Your system has a SATA III (6.0 Gb/s) interface so you should be able to gain the fully bandwidth of your SSD.

By chance is your HD a SATA II (3.0 Gb/s) drive? If you can look I up, otherwise give us the make and model info.

For now check your systems firmware level. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers.

Was this answer helpful?

Score 1

Comments:

It is a SATA III (Intel 7 chipset). The negotiated link speed is 6Gb/s (per System Report).

MacBook Pro 9,2

Boot ROM Version: MBP91.00D3.B0C

SMC Version (system): 2.2f41

by

How about the HD you were using what was it? Make & Model

by

Your SMC is out of date, it should be 2.2f44 (SMC 1.8). Also if you have El Capitan running your boot ROM would be newer (MBP81.0047.B2A).

by

The HD I'm using is a SanDisk Extreme Pro 480. I have El Capitan running, the boot rom seems to be the correct version, but you are correct, the SMC version is outdated. I'll have it updated and see if there are any changes.

by

You stated you have MBP91.00D3.B0C not the newer MBP81.0047.B2A. The Apple T/N is out of date the one I posted is updated by the OS installer.

by

Show 5 more comments

Add a comment

Add your answer

fernandodeschamps will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 224