General Motors' GMT400 platform.

67 Questions View all

Bank 2 oxygen sensor location

Does anyone know of a website that shows a diagram of the catalytic system. I got a OBD code PO430. I found out what that means , but I don't know where the " bank 2" oxygen sensor is located. Please help

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

3 Answers

Chosen Solution

Janet Fayette Bank 2 is the right (passenger side) of your vehicle.

Block Image

Was this answer helpful?

Score 1

Comments:

doesnlt help me at all. my system has single exhaust and only 2 sensors and i still hae no idea how to test and repair the wiring or even where to begin to try to find out !

by

Bill Huff what make and model is your vehicle and what error code do you get?

by

Add a comment

When referring to banks of oxygen sensors bank 1 is any sensor upstream the catalytic converter and bank 2 is downstream so bank one is before and bank 2 is after the catalytic converter always remember there can be 2 of each sensor on duel exhaust

Was this answer helpful?

Score 1

Comments:

i have single exhaust ! i upstream D/S, and one downstreeam P/S. the upstream has stopped working and codes out 0134 and 0155 codes. clearing them the light is off for several hours . but i have no idea how to find and fix the proble.

by

Bill clearing the code does nothing for fixing the problem , it just erases the code and starts the diagnostic series over again ,if your getting both codes odds are you have pooched the catalytic convertor . This is an excellent video to diagnose a convertor problem

https://www.youtube.com/watch?v=9VZ5K8n5...

If the convertor tests out ok then go ahead and replace the o2 sensors

by

Add a comment

not a good question because my 98 ck 1500 GMC only has 2 sensors. 1 upstream and one down stream. they are both new but the wirinf on the up stream has stopped working . code 134 and 155. no activity showing.

Was this answer helpful?

Score 0

Comments:

billhuffsr

Rep: 1

Posted: 41 seconds ago

Options

not a good question because my 98 ck 1500 GMC only has 2 sensors. 1 upstream and one down stream. they are both new but the wiring on the up stream has stopped working . code 134 and 155. no activity showing.

by

Add a comment

Add your answer

Janet Fayette will be eternally grateful.
View Statistics:

Past 24 Hours: 52

Past 7 Days: 268

Past 30 Days: 1,268

All Time: 11,819