Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

763 Questions View all

white screen of death, no apple logo, overheats in minutes

hi,

Recently my macbook pro encountered the white screen of death all of a sudden and it was still working perfectly fine. After reading many forums on line im still unable to crack this one out and didnt send it to the repair since mac repair informed me that it was a minimum of $800! The macbook pro is able to be charged and turns on normally but the apple logo loading screen does not show up, im unable to insert the Mac OS X DVD into the dvdram it seems like theres something blocking it (but im pretty sure i did not insert anything in i think its just the system preventing it from opening idk) and ive tried to reset PRAM and SMEC but they didnt work and after leaving the macbook pro on for a few minutes the area near the hinge ( between keyboard and screen) heats up really fast and it gets really hot. Any expert can shed some light into this matter? My world is incomplete with my macbook!

Thanks in advance!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

i have also tried all sorts of commands like command R, command S, pressing option etc but nothing changed other than the white screen! havent physically removed anything or opened up the macboom yet!

by

Add a comment

1 Answer

Most Helpful Answer

Try pressing the eject key or holding down the trackpad button when booting up to eject the disk drive. This may also be a hard drive / hard drive cable issue.

UPDATE 11/24/15

You may have a couple of things going on. The question mark indicates that it is not seeing a valid system folder. I suspect you may have a bad hard drive cable. Open it up, disconnected the optical drive cable and the hard drive cable. Boot from an external source.

Was this answer helpful?

Score 1

Comments:

hi thank you for the response, tried holding the trackpad button for about 1/2mins, no response from the disk, but a folder with a question mark pops up! What does this mean?

holding the eject button doesnt work either:(

by

It means it's fixed......sort of now you have to give it a system to operate on by either usb or sata connection from the motherboard.

by

Add a comment

Add your answer

leafybkk39 will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 9

Past 30 Days: 50

All Time: 1,031