Laptops manufactured by Asus.

1048 Questions View all

Wi-Fi always stays off. How to enable?

Hi, my UX305FA (Win10) has this red X on its Wi-Fi symbol, it saids "Not connected - No connections are available" when mouse over. The wi-fi toggle in NETWORK & INTERNET settings always stay off. And the wifi device option is grey-out in the Airplane mode page. Network adaptor is enabled correctly in Device Manager. It seems like the wifi is disabled by some kind of hardware switch.

I have try booting into Ubuntu (by usb) to confirm. Problem remains, and the wifi message is "Wi-Fi is disabled by hardware switch" .

Does anyone know if there is any hardware Fn key on this laptop to enable the wifi? There is none that I can find. The only network related Fn key is the airplane mode Fn+F2.

Any suggestion?

Asus zenbook ux305FA

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

Hi,

According to the user manual in the BIOS area under the Security tab -- I/O Interface security there is a Wireless Network Interface option to lock or unlock. The manual shows it as unlock you might want to check and see if yours is in the lock position.

Was this answer helpful?

Score 2

Comments:

It is in [Unlock] position.

by

hi,

can you turn airplane mode on and off using Fn F2?

by

Yes, airplane mode is functional.

Bluetooth is grey out when airplane mode is ON.

Wifi is grey out no matter what.

by

maybe you could try

make sure airplane mode is off

go into bios and "lock" wireless network save change, boot into Win check that WiFi is greyed out.

then go back into bios and unlock wireless network save change, boot into Win and check

basically toggle the setting

by

found this on the Asus website

http://www.asus.com/us/Notebooks/ASUS-ZE...

driver download for wireless - asus wireless don't know if this is yours -a driver to switch Airplane mode (wireless ) on/off dated 2015 /08/14

might be worth a look

by

Show 6 more comments

Add a comment

Your wireless controller may be broken our have loose connection

Was this answer helpful?

Score 0
Add a comment

Hi, I had the same problem.

I tried re-installing the WiFi driver. Still the same. My netbook is a dual boot seashell series. I opened the program with Asus Express Gate Cloud (firefox), went to settings , swithed the WiFi off & on & the WiFi switched back on. I was playing in this area a week or two before trying to get it to work & I must have switched the WiFi off.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Fan will be eternally grateful.
View Statistics:

Past 24 Hours: 59

Past 7 Days: 350

Past 30 Days: 1,660

All Time: 17,357