Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

858 Questions View all

Red X after HDD, screen and jack replacement

Good evening all,

I'm having some trouble with my 80GB iPod Classic.

Here's the story: I started by replacing the screen as the original was covered in scratches and dead pixels.

All was well, almost.

(I think) I was a little careless during the reassembly and must have inadvertently damaged the earphone jack assembly. It worked totally fine, however a few days later I lost audio in one of my earphones (note this iPod has had two jack/hold replacements in it's long life, though they were performed by a third party company) this whole ordeal was the first time I've tinkered with it myself.

So seeing as I'd replaced the screen myself I thought I'd have a go replacing the jack/hold. Which I thought was fine.

During the process I disconnected the hard drive as I was automatically in screen-replacement-mode and totally forgot that I was following different instructions. When I finished this reassembly I was faced with the dreaded circled red X. As I've had an issue with my hard drive in the past (previous red X during use, banging it off a table fixed it) I assumed it's time had come and I have purchased a new one. This replacement also resulted in a red X.

Performing a diagnostic shows everything is fine except for the HDD, which cannot be opened. "[Can't Open Device] ERROR! Diag Halt"

The ribbons seem to be connected fine, though I have noted that the problem has only been around since I disconnected the HDD from the logic board during the jack replacement. Could this be as simple a fix as me just not doing something quite right with the ribbons? I can't for the life of me figure out what else it could be.

Any help would be hugely appreciated.

Thanks,

James

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Thank you both for your speedy replies.

Argh, this is so frustrating!

I like the idea of the Zif connector, I'm just conscious of how much money I'm spending on bringing this thing back from the dead, I've probably spent about £60 so far with little joy.

I can still hear both HDDs "whirring" when I fiddle with the diagnostic, to me this suggests that the iPod definitely acknowledges them but can't do anything with them. I can't see how it could be a connection issue though, yet all the signs so far point to that being the case

by

Add a comment

2 Answers

Most Helpful Answer

James, it could be a cable issue (the cable the plugs into the HDD and then connects to your logic board or the logic board itself could of somehow got damaged. The logic board also has the connector plug for the headphone jack/hold switch, which could also be related to your headphone jack issues. Im afraid the only way to locate the issue would be to try a new HDD cable and/or a new logic board.

Was this answer helpful?

Score 1
Add a comment

jamescdavies, besides the great points made by TechyGirl I'd suggest a USB to Zif connector. That will allow you to check your HDD on your computer. That way, if the HDD is still working, you can be sure that you are getting the right part i.e. HDD cable or new logic board. If it is not, you need to start with your HDD as the culprit.

Was this answer helpful?

Score 1
Add a comment

Add your answer

jamescdavies will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 74