Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

368 Questions View all

Hard Drive not recognized, even after replacing HDD cable

Ok, so here's a weird question for you all! Normally I don't do these forum things, but I am backed into a corner!

First my MacBook Pro won't show the Apple logo, second, it doesn't see ANY hard drive EXCEPT Windows NTFS drives! I know right!? VERY WEIRD!

So I bought a brand new cable, installed it and low and behold, NOTHING changed! Still doesn't see any Apple HDD and ONLY see's a HDD with Windows OS installed, and no it won't boot to anything!

I insert my Yosemite install USB, it goes through the first install point with the Apple logo and install progress bar, then goes back to blank grey screen. Nothing else happens.

Install DVD with Snow Leopard on it, insert it, it does the same thing, goes through the spinning wheel thingy, then goes to a grey blank screen.

I have reset all PRAM, NVRAM, SMC settings, the whole nine yards. So at this point, I am pointing towards the logic board as the issue!

It turns on, NO APPLE LOGO, does the hardware OK normal Apple chime, then does nothing unless you are holding down OPTION at boot to select a drive.

I reformatted three known working HDD's three different manufacturers, and two 5400RPM's and one 7200RPM drive. I have not tried an SSD, I have three, but only one to try.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Tough one. Do you have Disk Utilities on the USB Yosemite? If so boot and see if you can format a know good Mac drive. Your system shipped with 10.6.6 +, the Retail Snow leopard is most likely 10.6.3 and will not work for an install. Do you have another Mac to attempt an install via Target Mode? Have you tried an internet install? I like an ethernet cable and hold down the option key or just do nothing sometimes on boot.

Was this answer helpful?

Score 1

Comments:

I have a Macbook Air 11" that I could use, but not sure how much of a benefit it will even be! Last night I did an experiment, I inserted several USB thumb drives, and it ONLY see's my USB Yosemite 64GB stick. Then I went a step further and inserted the hardrives via USB external. I have two USB external drives, and a sata to usb external drive adapter (allowing me to swap several different HDD's between MAC and PC).

Here's what I did with that, I put the USB adapter HDD on the Macbook Air, I formatted three drives, all MAC OS Extended (Journaled) and GUID Partition table. After that I ejected them and inserted each into the MB Pro and neither was seen. I then slaved them via the SATA-USB adapter.

by

Neither were seen, the only thing that shows up is the USB install disk that I had inserted. So I was thinking that I would just make the HDD's that I had bootable USB Yosemite disks, and see if that works. Because what it looks like to me is that these drives are not actually formatted to where it can be seen as a boot drive? It be a little tricky but if it works, who cares!?

The only problem with that is I need another Yosemite.app and I can't get that unless I download it from the app store. I'll google around, maybe I can get it like I do my ipsw's from my iPhones when they fail.

by

Did the new HD/IR cable have paper covering on the sticky surfaces? Where did you get it? I also use the wider more substantial 2012 cables.

by

So here's what I did this morning so far...

I did exactly as I said I would, I would take the HDD I have, the one that I tried to use as a hard drive, with no luck. I made it a bootable USB drive to use it as an install drive for Yosemite. After I made it a bootable drive and put OS X Yosemite on it, I slaved it up, and BOOM! It now see's the drive. Next step, cross-fingers, install it into the MAC as internal drive again. Result, SUCCESS! It now see's the drive inside!!

Next step, let it run and install OS X Yosemite onto itself, FAIL!

It does the EXACT SAME THING! NO DICE!

Even AFTER ALL THIS, NO APPLE LOGO! No booting to the drive and will not allow the install of the OS. I am BEYOND stumped!

by

Mayer, yes it did have paper covering on the sticky parts, I didn't remove it when I installed it. I got it new off of eBay, it is a genuine Apple cable.

by

Show 3 more comments

Add a comment

Add your answer

Aaron Belcher will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 21

Past 30 Days: 67

All Time: 953