The Audi A4 is a compact executive car produced by the German car manufacturer Audi AG. The 2002-2005 A4 was built on the Volkswagen B6 platform.

9 Questions View all

What would cause coolant temperature gauge to stop working?

temperature coolant gauge was working fine, then just started working sometimes. now it's not working at all!when i have driven for a while i notice erratic shifting in the gears & some loss of power. i am having troyuble trying to figure out the the cause behind it. please help!!

Answered! View the answer I have this problem too

Is this a good question?

Score 8

Comments:

hello everyone & thanks for your answers to my question . turns out the sending unit which is the sensor had went bad and needed to be replaced. so thanks again!!! :)

by

I had to put in a new motor in my 99 dodge 1500 sport now the atl & the water temp gauge will not work at all I have not been able to drive my truck becouse of this can you help.

by

I have a beautiful restored 1997 Dodge Dakota 5.2. My temp gauge is not reading hot but going the other direction. Normally it reads at 200 but is dropping down to almost the 130 mark. What does this mean? Help!

by

hello, how to fix my ATOS engine temperater, when the watersystem not erro?

by

Add a comment

10 Answers

Chosen Solution

i can only guess - but the coolant temperature sensor failed very often on those models

since the audi is CAN-bus controlled, i would use the A/C or my CAN-bus reader to get the actual error codes. i didn't found a good source for the A/C trick in english - only german sources - here is a google translated page: CLICK

Was this answer helpful?

Score 5
Add a comment
Most Helpful Answer

It's a shot in the dark, but I would start by checking the thermostat first.

Was this answer helpful?

Score 5
Add a comment

to verify if the sensor is what's causing the problem, disconnect the connecter from the coolant temp sensor, and jump a paper clip across the terminals. turn the vehicle on after doing this, and see if the gauge has moved in the dash at all. try the same thing with the connecter disconnected. if the gauge moves at all, then it is the sensor itself that has failed.

Was this answer helpful?

Score 2

Comments:

Trouble coolant sensor can stop engine

by

On my clio when the gauge is at 4 the car struggles to start and flashes stop and when engine starts it goes off ! Could it b the coolant sensor? ?

by

Add a comment

I have a 2001 Audi A6 2.8 for the last couple day I have been noticing the thermostat gage going closer to the hot I got off to check my aintfreeze and my oil thinking I may have a leak but the car was full of antifreeze and the oil is fine the engine was not hot at all I have no clue when it comes to cars plz help

Was this answer helpful?

Score 2
Add a comment

On the Audi the sensor is your problem

Was this answer helpful?

Score 1

Comments:

Excellent answer. Please read the comment that the OP left, right below the question, on Aug 16, 2010. It was the sensor and did get fixed. Also check the Accepted answer from July 31,2010 where it was suggested that it is a bad sensor....;-)

by

Add a comment

ECT (engine coolant temp sensor)

the ECT responds to change in coolant temp. by measuring the the coolant temp, the ecu knows the average temperature of the engine .

the ECT sensor is needed to controll many functions such as fuel injection, ingnition timing,variable valve timing, transmisions shifting ect.

Was this answer helpful?

Score 0

Comments:

whats is the ECT

by

Add a comment

I had the same problem happen today on my 92 Gmc sierra. It turns out the harness clip on the Coolant Temperature Switch snap off due to age I suppose. Anyway, I connected it and secured it until I can get a harness connect replacement (which for some reason is rather high in price for what it is). Cranked it up and took it down the road and the gauge works, it isn't loosing power when I come to a stop (it had stalled completely a couple of times earlier this morning), and I still have a little eratic shifting cause my tranny needs to be replaced. Ironic the same symptoms and problem here...wow. My radiator hose actually constricted a couple of times too. I constricted from the thermostat neck all the way to the radiator too.

Lee

Was this answer helpful?

Score 0
Add a comment

I have a audi a4 2001 model the temperature gauge does not work and it losses power such that it even fail to climb small hill.what can be the cause ,can anyone help please.

Was this answer helpful?

Score 0
Add a comment

I have a 2007 lincoln navigator the temperature gage goes up like crazy but vehicle is not hot I stop the engine turned back on and gage goes normal can some one help me?

Was this answer helpful?

Score 0
Add a comment

I have a Chrysler 300 05 radiator fans work engine is not running hot but temperature gauge doesn't register any ideas

Was this answer helpful?

Score 0
Add a comment

Add your answer

antonio will be eternally grateful.
View Statistics:

Past 24 Hours: 123

Past 7 Days: 926

Past 30 Days: 4,067

All Time: 105,499