Skip to main content

Repair guides and support for wireless and wired Apple keyboards.

188 Questions View all

Mac keyboards function and numeric keys not working at all

I have a basic wireless keyboard and all of a sudden my top row of Function keys and the number one to nine numeric keys and their shift-symbols don't work, nothing happens when I try to use them in any application. On the left of the number one, the `~ key works, and on the right the 0), -_, =+ keys work fine, as does the delete key. It really is only the one to nine keys and their corresponding shifted key.

I have tried re-pairing the keyboard, setting the default keyboard settings, various keyboard on/off combinations, etc. Initially I thought my child hit some sort of keystroke combination that turned these keys off, but now I think it maybe more than this.Nothing has been spilled on the keyboard, and it has not been hit or dropped.

Answered! View the answer I have this problem too

Is this a good question?

Score 4


I have exactly the same issue on my Mac Book Pro 2012 , 13"


Add a comment

1 Answer

Chosen Solution

Unfortunately it sounds like a problem with the hardware inside the keyboard. Since it's an entire row of keys, most likely a lead or two no longer has a connection to the keyboards main board. Since the keyboards are glued together repairing them is more or less impossible since it will be very hard to open them and then restore it to it's original state.

Was this answer helpful?

Score 3


This is probably too late for the 2 people from 2015 that originally posted the issue, but this "chosen solution" is likely wrong. The "entire row of keys" has 2 functions and there is a box in the keyboard settings to enable or disable the pre-built "Apple" functions or for them to behave like normal funtion keys without having to press the fn button.

Navigate to system preferences. From the main menu click on the keyboard. There are several tabs at the op inside the keyboard settings, select the keyboard tab. At the bottom there is a box that says "Use F1, F2, etc. keys as standard function keys - when this option is selected, press the Fn key to use the special features printed on each key. So there you have it. The keys behave 2 ways. 1 of the ways requires the Fn key. This box in system preferences switches the ways the keys behave and which function of 2 ways that will require you to hold the Fn key down.

The short answer. Toggle the box in keyboard settings.


I doubt this is hardware related. I have found several instances of people saying 1-9, F1-F9, all shifted characters/functions on those keys and RSHIFT or LSHIFT stopped working in close proximity to running an update. I can't think of any hardware failure which is caused by software. When I can get this wireless keyboard back to the computer it was paired with, I will try keyboard reset. But if the firmware from an update was bad, a reset is not going to fix it.


timmothygardner - the original post wasn't about the function keys but the number keys.

I have the same issue on my wired apple keyboard - nothing to the left of the = key is working on that row, everything else is fine.


Same problem before update Big Sur eleven.six, then it worked for a bit.. and then, after some days, numbers one-nine don't work again...


Add a comment

Add your answer

Antje H will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 18

Past 30 Days: 71

All Time: 12,960