Skip to main content

Fix Your Stuff

Right to Repair


Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1590 Questions View all

partition failed wiping volume data to prevent future accidental probi

I get the error in the title when trying to partition a newly installed Samsung EVO 850 SSD into the Mac. Same error with a Samsung PRO 850 which I returned to the store.

I have asked Apple Support for help a few months ago:

When I put an old "non-SSD" disk into the computer I can partition just fine. Looks a lot like this issue:

Do you have any experience with this error. Do you think it would be a solution for me to install a new SATA cable like this?[0]=9ed2cc5b64bd3cdbd919d99ee324137d

Hope you can help.

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

3 Answers

Chosen Solution

Do you have any external case or USB to SATA adapter to hold your SSD? If you do I would first see what happens setting up a clean partition & format the partition. Make sure your drive is set with GUID. If that works then you'll need to focus on how you have the drive connected here. If you swapped out the HD then the HD SATA cable is bad. Apple did have a bad run of cables so it's a strong likelihood.

If you are using a dual drive setup then you have encountered a known issue with the optical drives SATA port is not up to SATA III spec. Review the note entries at the bottom: OWC Data Doubler

  • MacBook Pro 13" models: Apple does not support the use of 6Gb/s drives in the optical bay. While we have observed a high rate of success using SATA 3.0 6Gb/s drives in Apple 13" bays where 6Gb/s link is present, some systems may not operate properly with this setup. For guaranteed reliability/compatibility, we suggest 6Gb/s drives be used in the main drive bay only, and 3Gb/s hard drives or SSDs be used in the optical bay when a two-drive configuration is desired. We cannot guarantee proper or successful 6Gb/s drive operation in the Apple MacBook Pro 13" optical bay.

It makes no difference who's carrier you use the issue is with the SATA port logic in the system. What this means here is your Samsung SSD is not able to be used in a optical drive carrier. The reason here is the SATA speed of your SSD is auto setting so it tries to sync with SATA III but because the clocking is off it can't sync and yet it can't drop to the lower SATA speed. This is were you need a fixed speed drive.

The last thing here is making sure both your systems firmware & the Samsung SSD's firmware is upto date. Here's the Apple T/N you'll need to review to check and if needed update your systems firmware: About EFI and SMC firmware updates for Intel-based Mac computers. You'll need to prep up a special CD to run the Samsung firmware updater. Here's the Samsung Upgrade page: Samsung SSD Firmware Updates for Mac Users. For either make sure your system is stable as any disruption can corrupt the firmware causing complete failure.

Was this answer helpful?

Score 7


Thanks for your reply Dan.

As I pointed out in the Apple Support case I tried putting the SSD in an external USB case and that worked:

I guess my next move is to order a new SATA cable.


I ordered a new cable which I have just put into the computer, and it works. Thanks for your help.


Happy it all worked out, enjoy!


Thanks for the helpful answer, I swapped the old hd to the optical caddy and installed the ssd on the main hd connector and it worked right away.


Add a comment

Just had the same problem replacing the Hitachi HDD with a Samsung 850 EVO 250 GB SSD in a mid 2010 13" MacBook Pro. Tried everything to initialise/format the SSD (spent hours researching solutions and creating bootable USB drives etc.) but the Partition option was greyed out on Disk Utility and the Erase option kept failing with the message 'partition failed wiping volume data to prevent future accidental probing'. Was just about to order a USB-SATA adapter to try the SDD externally before ordering a new SATA cable but decided to try something I'd read for another problem 'unable to unmount volume for repair' (see below). I simply taped 2 metal edged areas and it worked like a dream - didn't need to use the alcohol wipe (many thanks to Tech Harmony for this).....

"Basically the hard drive cable rubs against the edge of the optical drive's metal tape and probably gets shorted in some way. The solution is to put a little piece of electrical tape between the SATA cable and the optical drive. When I tried this with a Samsung SSD the first time it didn't work. So I used some rubbing alcohol (99% in this case) and swabbed the back of the SATA cable where it rubs the optical drive.

Then I put the electrical tape on the optical drive edge instead of the cable (since it was easier this way anyway) and voila, drive works now with no problem."

Hope this helps someone else.

Was this answer helpful?

Score 4


I can also confirm, add tape on the side of the optical drive, it works, but I would also replace the cable. took me a week and even after ignoring this answer. Temporary fix but also works.


I was getting the same 'partition failed wiping volume data to prevent future accidental probing' on a Mid 2010 MacBook Pro 13" with an internal SSD. After opening up the case, removing the drive, putting a small piece of electrical tape on the edge of the optical drive case as described above, then reconnecting it all, the volume erased properly. I don't know specifically if it was the tape that solved it or if reseating the the SATA cable solved it. Either way. It is working now. Thanks for the tip!


Add a comment

The same thing happened to me and it took me hours to get here. After hours and hours of reformatting the drive on my iMac using an external SATA cable (3 external SATA cables to be exact), I could not get the partition to show up un-greyed. I knew all 3 cables could not be faulty but there was no other explanation why the MBP would not recognize the new formatted internal drive. On occasion, during my multiple attempts to format the drive as internal in the mid-2012 i5 2.5GHz 8GB the drive would show up in Disk Utility but every time I tried to format it as an internal drive I would get the error “wiping volume data to prevent future accidental probing failed”. I tried an old HDD I know worked less than a month ago and still I was no closer than I was 8 hours before. Kept getting the same errors. I came across this guide and I just replaced the SATA cable. I didn’t think that was the issue because I was getting all of the other error codes. Replace the SATA cable and save yourself 8-10 hours of research. Thanks for the help!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Carsten Kring will be eternally grateful.
View Statistics:

Past 24 Hours: 23

Past 7 Days: 89

Past 30 Days: 440

All Time: 42,557