The Sony Xperia Z3 is an android smartphone released in 2014 known for it’s long battery life and durability.

104 Questions View all

No Service at all

My Z3 says no service, my sim card works well at other phone,

and my contact in my sim card still can be viewed.

What have gone wrong, and what should I do?

Thank you

Answer this question I have this problem too

Is this a good question?

Score 14
Add a comment

19 Answers

Most Helpful Answer

Hi Tobias,

I got the same problem. I tried to update using PC companions but it didn't work, still the same old 5.0.2. Let's wait for the 5.1.1 update, hope will be sooner. By the way I'm from Canada.

Was this answer helpful?

Score 2

Comments:

Hello, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Ok Folks...Its the antenna board located at the bottom of the phone. The part costs $9 on ebay. Just confirmed thats the problem. Once you replace that small logic board, it'll work fine. Guaranteed.

by

Add a comment

Hello Marknovie,

I was just updated to 5.1.1, and still the same problem.

I don't think it is my software mistake

I'm from Indonesia by the way

Was this answer helpful?

Score 2

Comments:

I still get no service. how's your's?.

by

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Add a comment

buenas-noches-amigos-tengo-el-mismo-inconveniente-llevo-dos-meses-con-el-lo-lleve-donde-lo-compre-y-me-sacaron-diciendo-de-que-fue-culpa-de-la-pantalla-por-que-esta-dañada-pero-el-móvil-funciona-correctamente-en-todo-su-aspecto-normal-le-cambiaron-el-software-pero-igual-entonces-decidí-llevarlo-ala-sony-y-por-el-momento-me-lo-tienen-me-llamaron-y-me-dijeron-que-en-esta-semana-me-dicen-cual-es-el-inconveniente-por-el-momento-me-dieron-tres-respuestas-las-cuales-pueden-ser-la-causa-la-primera-es-que-el-teléfono-este-desconectado-la-antena-por-eso-no-percibe-las-ondas.

la-segunda-de-que-el-teléfono-entro-ilegal-al-país-y-fue-bloqueado-y-la-tercera-problema-de-agua-o-húmeda-que-daño-la-antena-pero-descartan-la-ultima-por-que-los-sensores-de-humedad-están-respondiendo-de-que-el-equipo-no-le-ha-entrado-agua-soy-de-Colombia-apenas-me-den-el-dictamen-de-la-causa-se-los-estaré-sabiendo-muchas-gracias-por-el-momento-de-tomarse-el-tiempo-de-leer-mi-opinion

Was this answer helpful?

Score 2

Comments:

gracias mi amigo

by

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Add a comment

Sim card working but no services problem...

Was this answer helpful?

Score 2
Add a comment

Hi team, well i got the same problem on my experia z3 , No Service even the phone read the sim card, i also thought it was a software problem, unfortunately its not, its a hardware, its all about a green small mother board that control the phone network, here is a link for this peace (http://www.ebay.com/itm/Sony-Xperia-Z3-D...), after replacing it, every thing went great :) good luck, Alaa Eddine, Algeria

Was this answer helpful?

Score 2

Comments:

I'd call that a daughter board but anyway that connects to the cellular antenna on your phone. If that isn't mounted properly with the housing to hold it you may have this issue. Otherwise probably damaged.

by

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Add a comment

Just look at this link may help you

http://www.thetruebox.com/sony-xperia-z3...

Was this answer helpful?

Score 2

Comments:

You Helped Me thank you

by

Thank you, man this link was great and helpful

by

Add a comment

no servic but sim card work in anather fhone

my fhone sony xperia z3 just show no service.

what should i do?

Was this answer helpful?

Score 1

Comments:

Hi tanvir, i had the same problem, and i did change this piece: "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector"

please feel free, to contact me again.

My phone worked after replacement of this piece perfect.

kind regards

by

Please how did you do to change it? Can you explain step by step? thanks in advance.

by

Add a comment

Turn off lte, Go to settings, Mobile network, select wcdma prefered, search provider, and turn on lte, disable mobile network, and enable again

Was this answer helpful?

Score 1

Comments:

I just marked WCDMA prefered and it worked for me - I got my range back.

Done on Xperia XZ

by

Add a comment

have same problem, tell me if u have any solution

Was this answer helpful?

Score 0

Comments:

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Add a comment

Still no fix for this? I'm having the same problem.

Was this answer helpful?

Score 0

Comments:

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

by

Add a comment

https://www.youtube.com/watch?v=wP5W9c6A...

Was this answer helpful?

Score 0
Add a comment

Ok Folks...Its the antenna board located at the bottom of the phone. The part costs $9 on ebay. Just confirmed thats the problem. Once you replace that small logic board, it'll work fine. Guaranteed.

Was this answer helpful?

Score 0

Comments:

it didn't work for me at all. I have also tried luck by changing the antenna cable nut all in vain. The problem might lie in the antenna board

by

Add a comment

I know this thread is old, but I've recently run into the same issue and found a solution. In the settings, there is an option for "Reset Network Settings". This will remove all your wifi networks and any downloaded access point settings, but fixed the issue for me. Hope this helps any future solution seekers!

Was this answer helpful?

Score 0

Comments:

Hi Sameer, I'm having same problem currently, not sure where to find 'reset network settings' option?

Gravely appreciated

by

If you open settings and search for "Reset", then it will be one of the options. It's actually in Settings > Backup and Restore > Reset Network Options (before the last option in the bottom)

by

Add a comment

Hello, that fix worked for me as well, i did change the "Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector" and the phone had again service with all sim Cards. Thanks Alaa Eddie Mohamed

Was this answer helpful?

Score 0

Comments:

How we can change it?

by

Add a comment

hello..phone sony sye nie msih bru guna..tp x dpt kesan sim kad digi...sim celcom bolah jer..tp x tau knpa sim digi x boleh pla..boleh tlong tak ASAP..TQ

Was this answer helpful?

Score 0
Add a comment

hallo...phone sony sye nie msih bru guna lagi..sye x tau knape tp sim digi xde line tp sim celcom boleh jer..sim digi no network tp klo sim celcom ok xde msalah..tlong ASAP ..Tq

Was this answer helpful?

Score 0
Add a comment

Sony Exparia z3 sim card showing but no service plz fixit my problem

Was this answer helpful?

Score 0

Comments:

Hello Mak, you have to remove the Sony Xperia Z3 as shown in the Video: https://www.youtube.com/watch?v=x56gWKCF...

then you have to replace the broken item: Sony Xperia Z3 D6603, D6643, D6653, Sub PBA-A Antenna, Antenne Board Connector

and after it work again the service with every simcard.

kind regards.

by

Add a comment

I have the same problem, changed the antenna board too but it still shows up as "No Sim Card Inserted, No Signal". Tried Factory Reset too with no joy. Anyone got anymore suggestions?

Was this answer helpful?

Score 0

Comments:

i have same problem...no sim card inserted, but after few minutes it asks for PIN and then no signal and no service

by

Add a comment

I went to shop to get it activitied then come home and done something to this sim and I was playing with the phone and I pressed the wrong button but I don't no what button now it's saying no service so can u help me to get it activied please

Was this answer helpful?

Score 0
Add a comment

Add your answer

Tobias will be eternally grateful.
View Statistics:

Past 24 Hours: 68

Past 7 Days: 443

Past 30 Days: 1,234

All Time: 27,961