Model A1419 / EMC 2806 & EMC 2834/ Late 2014 or Early 2015 or late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 Processor / Retina 5K display

150 Questions View all

Create Fusion Drive problems

I have a 27" iMac with Retina 5K display - Intel Core i5, current OS-X is Yosemite 10.10.4.

I changed out the 1TB HD with a 6TB HD. Reinstalled software, created two partitions (2 separate drives).

MAIN GOAL: To create a Fusion Drive.

PROBLEM: cannot unmount disk using terminal while booting from usb drive. I have found tons of instructions online, this site as well, none work.

Disk utility will not unmount or erase the drive that has the recovery partition (actually on the 6tb drive, not on the apple SSD). What I need to find out is how to TOTALLY clean wipe each drive with no recovery partition, then I will be able to fuse them together and then add on a new install of Yosemite.

The drives are already wiped clean of data, but still have the recovery causing the issue. I just want to Fuse the GD things together.

I have watched a ton of videos and blogs that are supposed to deal with this, but so far none have worked. I've been using terminal to try to unmount and force unmount and fuse the drives. I have the same problem on 2 separate iMacs. Any help is appreciated. I have been working on this for 3 days and am getting very frustrated.

Sites I've tried and their instruction failed:

Mac mini (Late 2012 and later), iMac (Late 2012 and later): About Fusion Drive - Apple Support

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

OK, I think I know what your problem is here.

I suspect you didn't first break the fusion set (Fusion Drive) the system had when you started. That would be the 1TB drive and the SSD it came with. You'll need to put the 1TB drive back in so you can break the set. Basically, you need to tell the systems firmware & SSD the drive is being swapped out. Once done you're halfway there!

The next step here is leaving the new drive with just one partition fused drives can't handle partitions as it doesn't have a way to bond with a given partition (excluding the normally hidden recovery partition).

To do this correctly you'll need to bootup on an external drive to correctly configure the HD and then create the Fusion Drive set. The rest of the information you have is all you need.

Was this answer helpful?

Score 2

Comments:

Can I break the fusion drive using the original 1tb hdd as an external drive?

by

The firmware ID'ed the drive via the SATA port (drives S/N). The USB connection won't get you there. Sorry ;-{

by

Add a comment

I also removed the hard drive prior to breaking the fusion drive. I installed an SS drive. Now I see two drives when I boot into the system. I see a Flash Storage and the SSD drive. Both drives appears to carry the same information and same size. How to I fuse these two drives so that it appears as one.?

Was this answer helpful?

Score 0

Comments:

To start with two SSD's can't be used in a Fusion Drive setup. You will need to put back the original HD that came with the system to break the fusion drive set. Then you can setup a dual drive setup where the first drive will be the boot drive and the second drive will be your data drive (two independent drives).

Thats the best you can do here.

by

Thank you Dan.

Is there a way to break the fusion drive by connecting the HD externally?

Can you please provide a link or some instructions on how to break the fusion drive should I decide to reopen the iMac to do the task

Thank you in advance for the response

by

Thank you. I will definitely try this

by

Add a comment

Add your answer

William Evans will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 17

Past 30 Days: 73

All Time: 1,849