Skip to main content

Compact device for setting up a home wireless network

16 Questions View all

no light, no network, no warmth

Hi All,

For 3 year my airport did work very well. Now it seems dead..

Tried to open it up. can not see how to.. anyone idea?

Resetting did not work, so i guess powersupply is broken??


Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

4 Answers

Chosen Solution

is it a (M9470LL/A, model A1084) or a MB321LL/A, model A1264

but to be honest - it might be a good idea to give this to somebody with a good knowledge of those devices - it could be very dangerous to tinker with those devices

Was this answer helpful?

Score 2


model A1088 :-)

Yes. i already ordered a new one....


Add a comment

I have same issue with my APX Model 1264. My research online showed that most likely problem is busted power supply. Mine is not totally dead, the light turns off and no more wifi network once the device heats up.

There is a forum regarding this issue in

I gez there is a work around this by attaching a new power supply.

Good luck.


Was this answer helpful?

Score 1
Add a comment

I recently opened my AE to re-rout the power supply. However, this ended up being unnecessary. As soon as I got it open I realized the lithe ribbon cable had just fallen out. I suggest you try plugging it back in before you re-wire the circuit.

Was this answer helpful?

Score 0
Add a comment

I solved the problem of my airport express lights that were not on. I had no power , no WiFi, no nothing. I took the advice of someone else on this or some other questions and answers. I pushed the plug into the back of it extremely hard. LIGHTS ON!!!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Robert will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 8

Past 30 Days: 32

All Time: 9,894