Apple released the MacBook Pro 15" Retina with a new display that has a 2880-by-1800 resolution.

954 Questions View all

Problem with External HD mounting and Disk Utility

Hi. I'm using OS-X Yosemite (10.10.3) on a 15" MacBook Pro Retina

I've been using my 2TB WD My Passport Ultra hard drive since around February of this year.

Earlier today when I plugged it in, the Hard Drive didn't show up in my devices in finder. So, I unplugged and tried again. Still nothing. Then, I went to Disk Utility and found that the drive was there, but the partition wasn't mounted and is greyed out. So i tried to verify / repair the disk but have gotten a couple different messages. One being: The partition map needs to be repaired because there's a problem with the EFI system partition's file system The other being Some information was unavailable during an internal lookup This message has shown up more than any other.

I've been able to get in and look at my files once to try to copy the files from the drive after a message popped up and said: Couldn't repair the disk, but I could still open or copy files on the disk but can't save changes to files on the disk

But, I encountered an error that was something along the lines of Operation couldn't be completed because the item "..." is in use. But the file I was trying to copy wasn't open or in use by any program.

SO, I'm in pretty desperate need of some help with this. I have some very important files on this drive that I can't afford to lose. A lot of it irreplaceable. Any help at all would be very much appreciated! Thanks a lot!

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Most Helpful Answer

Did you bang your disk or did you pull the cable in the middle of a read/write operation?

When a drive gets this way it is fragile! What you do next could make recovery harder. So you don't want to alter it too much until you have copied off as much as you can (just in case).

If you banged the drive while it was running you most likely crashed the heads and a part of the disk platters are damaged.

Now you're between a rock and a hard place:

  • The best answer here is to send your drive out to a data recovery service. Even then they can only go so far and it will be expensive!
  • If you can copy off the important files you need then you could take the chance in repairing the drive via software but that will only work if the drive media and heads are in good shape.
  • Lastly, you could try to get it replaced directly from Western Digital. But they won't recover the data under warranty.

Was this answer helpful?

Score 1
Add a comment

Add your answer

ryanh92nin will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 13

Past 30 Days: 64

All Time: 2,410