Model A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5 or 3.4 GHz Core i7 Processor

318 Questions View all

New power supply, won't boot, still only one LED

My Mid 2011 iMac 27" started to act weird soon after I bought it 2nd hand. Sometimes it didn't wake after going to sleep. A silent buzz could be heard from inside the iMac when the power was supposed to be on. It booted after I kept trying to turn it on and off (I could tell whether it was on or off from the buzz) repeatedly. This happened a few times, with each time taking longer to get the iMac to boot. The last time it refused to boot no matter how many times kept turning it on and off. Only the leftmost diagnostic LED was green.

Today I received a new power supply from iFixit and replaced the original one with it. The iMac still won't boot up, but at least the weird buzz sound is gone. Now when the power is on, there is a very silent hum from the power supply that seems normal. Same situation with the diagnostic LEDs: only the left one turns green.

Any suggestions what to do next?

I really hate having paid for 1200€ for the machine, now 150 € for the PSU and who knows how much more until it's fixed. Could've bought a 2013 iMac with that money instead...

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Please give us the last four figures of your serial number as there are a couple of recalls on this machine.

by

The last four figures are DHJW.

by

Add a comment

1 Answer

Chosen Solution

Your machines serial number is on a recall list. Contact Apple and see if they will repair it for free:

http://9to5mac.com/2013/08/16/apple-open...

Was this answer helpful?

Score 1
Add a comment

Add your answer

jonipekkaluomala will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 131