1.8GHz dual-core Intel Core i5 (Turbo Boost up to 2.8GHz) with 3MB shared L3 cache

321 Questions View all

Lower Case 'p' not working with my keyboard. Getting '\p0'

Been having this issue for a few months. My p key will not actually type the 'p' character. I will get some pretty odd behavior from pressing the 'p' key such as lowering my volume to seeing a '/p0' character typed out on the screen.

Originally started off as intermittent. I was originally able to resolve it by spamming my Caps Lock on and off repeatedly to get it to behave normally again. Now it seems determined to not work. The crazy part is if I turn Caps Lock on, I can type capital 'P' with no issues at all. If I spam the Caps Lock on and off now I'm lucky to get a single lower case 'p' before it start acting funky again.

I followed the typical suggestions. Checked to see if it were mapped to another function in Settings - nothing found. Did the NVRAM reset which was mighty tricky when 'p' is one of the characters you need. Still no luck. I even use boot camp and have this problem on my Windows 7 install.

The 'p' key itself is obviiously registering button presses so I'm thinking it's something internal, bad i/o cable or worse. I'm just curious if anyone's seen this kind of behavior and has had any success with replacing it?

I suspect a high cost to repair by bringing it into an Apple store and way outside the warranty. If I'm gonna try to take this thing apart, I want to make sure it's worth my time.

Answered! View the answer I have this problem too

Is this a good question?

Score 1


I have the same problem also.

Sometime it worked and can be used a few weeks until I typed some keys with "p", and then "p" can be used again.


Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Answers

Chosen Solution

I would start by carefully popping off the key cap and the neighboring caps so you can clean the area of anything that spilled onto the keyboard. Start by making sure the system is off and if possible disconnect the battery.

Use a cotton swab (Q-Tip) slightly dampened in distilled water (not tap!) wipe down the area. Next you'll wipe the area again this time with a good quality Isopropyl alcohol (85% or better). Using some can'ed air softly blow the area down to help speed up drying. Put the keycaps back on and try the system now. Any better?

As to the next step if this failed. Sadly, the keyboard is mounted to the upper case assembly. It is quite a lot of work to replace and the part is not cheap! You may want to think about using a USB or wireless keyboard.

If you really want to get this fixed here is the IFIXIT guide: MacBook Air 13" Mid 2012 Upper Case Replacement. Here is the IFIXIT part: MacBook Air 13" (Mid 2012) Upper Case with Keyboard. Just to give you an idea on the amount of work and the parts cast.

MacBook Air 13" (Mid 2012) Upper Case with Keyboard Image


MacBook Air 13" (Mid 2012) Upper Case with Keyboard


Was this answer helpful?

Score 2
Add a comment

got the real fix. Go to system

Was this answer helpful?

Score 0
Add a comment

Ok I started to write the real fix and, before I even finished writing, didn't work. Soooo. Still trying to understand what the final answer is here. Replace the whole keyboard? Or logic board? Makes no sense. There's enough people writing on this here that it seems like this shouldn't be my responsibility to pay for it. I've taken good care of my mac, and I took it to a simply mac who reset and it woke back up that way.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Zenmaster Jeff will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 37

Past 30 Days: 162

All Time: 8,089