How to fix iPhone 5s stuck in DFU mode that can't restore?

One evening (about two days ago), my iPhone shut off randomly. It did this twice more with shorter intervals, about an hour to a couple of minutes, and the screen would flash blue before it shut off.

Now it is stuck in DFU mode. I've tried restoring it both with a PC and a MacBook Pro. On both, either the restore hangs at 'waiting for iPhone' or I get Error 21. I've tried replacing the battery to fix this, and once I tried this, I plugged it into the wall charger, pressed the power button for about 30 seconds and the screen flashed green, and then after holding it some more it turned on, but wouldn't turn back on afterwards, it's still stuck in DFU mode, I've tried more than one cable and different USB ports.

This is second hand, but I've had it for about 8 months, I replaced the front unit (screen, digitiser, front camera, home button ect.) back when I bought it. iPhone has no history under my care of being dropped or water damage in my care and water indicator hasn't been tripped. It’s still recognised as a device when I plug in my phone.

Does anyone know what I can to so that I can get this up and working again?

TL;DR iPhone stuck in DFU mode, won't restore. Turned on once after replacing battery but now won't, any ideas?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment