MacBook Pro models with a 15" display

5148 Questions View all

Put used board in and still no backlight

Any help?

MacBook Pro 5.1 unibody late 2008 , 1286

Purchased a used logic board and all works except backlight on lcd screen.

Person who sold board said this board came from a MacBook Pro 5.1 820-2330-a logic board, number is the same as mine.

Still no back light, also my old board did not have an inverter attached, but he says his did. Could this be the reason for the lcd not working

Any help would be great!

Roger

Old turkey here are the photos of the two different logic boards I was talking about. But these logic boards have the same part number 823-2330-A. Please note on one board the connector in the middle, what is it for? Perhaps the cable for the inverter? Thanks! Roger

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Sorry I'am trying to learn how to post the photos!

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Roger, yes absolutely. If the board that you replaced used an inverter, it is a different board. You will need a board that has the LED driver circuit on it. Those boards are not interchangeable.

Was this answer helpful?

Score 1

Comments:

Thanks old turkey I appreciate the help. I will send this one back and try to get another one that matches correctly!

Roger

by

Old turkey,

Would you happen to have a photo of a logic board 820-2330-A that shows the connection for where the inverter cable attaches?

Thanks,

Roger

by

The only 820-2330-A I have is the one with the LED driver. No connection for an inverter. Have you checked the 820-XXXX number on the board that you have? Make sure it is the right board. You could post an image of your boards so we can check it with you.

by

Ok I will post photo of my board!

by

Both boards have the same number 820-2330-A. But one board is for a MacBook Pro with inverter for the screen. I will post both boards so you can see! There is an unused connection port in the middle of the board on the used one , it is that port that baffles me. I think it has something to do with the inverter cable, but I would need to see one to make sure. Anyhow, this board wont work for me. Any suggestions on getting a reasonable used board somewhere?

by

Show 4 more comments

Add a comment

Add your answer

Roger will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 124