Skip to main content

Harley-Davidson Sportster Motorcycles from 1986 to Present.

34 Questions View all

Starting problem with ignition?

I have a 2012 Harley-Davidson Sportster Evolution. I have NO digital clock/screen, horn,indicators,rear back/brake lights, reg light

I have engine start

Turn key to ignition,it starts,turn key slightly back a couple of mills and everything comes back on.

So between ACC-IGNITION.I have connection.

I also have digital clock display stand down,when it is up.

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

4 Answers

Chosen Solution

faulty ignition due to key vibration,

buy after market round key ignition with 3 wires,Disconnect battery, splice into wiring loom, use electrical connectors to connect new wires into loom wires,If not get a electrical Mechanic to do it for you,Thats what i did cost £25to buy £20 to fit.job done,

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Sounds like your ignition switch has a bad connection or contacts inside. Do you leave your bike outside or is it in a damp area? Try spraying some contact cleaner in the switch. Let it dry and see if that helps.

Was this answer helpful?

Score 3

3 Comments:

I have a 3 wire aftermarket ignition switch due to someone stealing mine. I have a 2019 1200 sportster and I bought one online and it has three wires but the harness from the old one only has two wires I bought new spark plugs and a battery but I cannot for the life of me figure out where these wires go I’ve tried different combinations and I cannot seem to get any power whatsoever. Unfortunately that’s my only ride to work I’ve been paying $40 a day to Uber with a brand-new motorcycle sitting outside

by

Hey bro by chance did u ever figure it out I have same problem and have had no luck and am stu k in yhe water

by

All you need is a 200ohm resistor between the two wires that connect to ignition. The bikes canBUS system senses that there’s not the ignition resistance of the oem. You don’t even need an ignition switch, just a 200ohm resistor

by

Add a comment

Thanks george,but its none of the above you wrote,My Harley is garage,I finally found out it was a contact inside ignition that had broke away due to flat keys riggling about because of vibration of engine,all 2015 wide glides also have same problem and have been recalled,over 3000 bikes.

I had a new ignition fitted with round key,Problem no more.:)

Kind regards Sam

Was this answer helpful?

Score 1

2 Comments:

I got a 1999 less 10000 miles riding it noticed the milage wuz blank got to where I needed to turn turn signal didnt work got it home killed it tryed to start it bck up it acted like battery wuz weak just got chickn sound what's my problem

by

Try the battery test it 13 to 15 volts anything under 13 it’s toast anything over 16 it’s the voltage regulator. Reading 12 volts and under then check the stator @yota1967

by

Add a comment

Block Image


I had the same problem. Ended up being rust inside the ignition switch. I had to store it outside for a few weeks. Had a cover on it, but the moisture rusted some contacts inside the switch.

I took the ignition switch off, removed the C-clip retainer, GENTLY pried out the round plastic piece holding the contacts inside, cleaned everything really well and removed rust by soaking in penetrant and scraping, put it back together and worked perfectly.

Was this answer helpful?

Score 1

2 Comments:

I have 2011superglide battery is draind when it starts l ride 2 mi starts shuttin on and off then dies anyone know what causes that

by

The stater switch?

by

Add a comment

Add your answer

SMUDGER will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 10

Past 30 Days: 54

All Time: 10,006