Model A1181 / 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1361 Questions View all

backlight does not work.

Hello I have a mc240ll/a and the backlight does not work it only turns on for about 2-4 seconds on start up and turn off. I already replace the inverter and inverter cable. I tried the computer on another monitor and it works.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

What is the size of your display? 13.3 in.?

If I had to guess i would say you have a bad display :(

by

@Tim - please read the whole question and the answers already provided. This is a 15" model and it uses CFL's. Yes, one could also replace the complete display assembly, but that's more expensive.

by

Add a comment

2 Answers

Chosen Solution

Have you tried resetting the SMC to see if that fixed things? If you have then I suspect the CFL lamps in the display are worn out.

Was this answer helpful?

Score 2

Comments:

Yes I have tried resetting the SMC but no luck. Thanks for your answer where could I get the CFL lamps ?

by

Getting hard to find, give these folks a try: CCFL Warehouse.

by

Thanks I looked in Ebay and Amazon but aint find them there. Ill give them a try and is there a guide I can follow to replace it ?

by

Add a comment

Can i ask how did you reset the SMC please? I have the same issue with my mac... I open the screen and the backlight flicks on for 2 secs then goes off and stays off, once in a blue moon it will stay on but if i close the screen or switch it off then its near enough impossible to get it back on? Thanks

Was this answer helpful?

Score 0
Add a comment

Add your answer

allan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 167