Released in April 2011, the D5100 replaces the D5000 as one of Nikon's popular consumer DSLR cameras. It features a replaceable Nikon F-mount lens.

44 Questions View all

autoexposure error message in window

camera was dropped and now displays "autoexposure error" message and will not work in auto mode. What can be done?

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

2 Answers

Chosen Solution

Sadly, It sounds like the lens or the lens mount got damaged so the electrical signals to the iris controls is not functioning. If you can try a second lens does it fail with it as well? If so your issue is within the body if it works then you may want to think about a new lens Vs repairing as the cost of fixing maybe close to the replacement price.

Was this answer helpful?

Score 1

Comments:

Youtube your issue and there are a couple videos that show a very easy fix. It requires adjusting a couple of the hex screws just inside the mirror if I remember correctly. There is a specific way to turn the wrench and it worked for my Nikon 5100. I also was told that many experience this and dropping it was not the cause of their camera error. It is most likely something Nikon should look at under manufacturer defect. Hope that helps.

by

Hello, can you please send me the links of these videos that show how to fix this autoexposure error issue?

by

I have the same issue and can't seem to find any videos regarding this issue. Please help and post link of video thanks.

by

By the way my d5100 only works on manual mode.

by

Add a comment

I had a smilar experience 2 years ago. The best option is to setthe dail to Manual (M) it should work

Was this answer helpful?

Score 1

Comments:

thank you! :)

by

Add a comment

Add your answer

Max will be eternally grateful.
View Statistics:

Past 24 Hours: 5

Past 7 Days: 35

Past 30 Days: 80

All Time: 3,246