Canon's Rebel XT is one of Canon's original consumer dSLRs. Also marketed as the EOS 350D and the EOS Kiss Digital N.

20 Questions View all

I keep getting an error 99

I tried to take some pictures with my camera recently and it keeps giving an error 99. I tried cleaning the lens contacts, I even tried using a different lens as I have 3 for this camera that didn't work. I tried a different CF card as I have 3 of these also and that didn't make a difference. I have tried with the flash and without the flash, even tried without a lens at all and everything I tried resulted in an error 99. I am going on vacation in 2 days and would like to resolve this myself if possible or I won't be able to take the camera with me. Please help

Answer this question I have this problem too

Is this a good question?

Score 3

Comments:

I started having the same issue after I bought a CF card adapter and trying to use a MicroSD card. So I inserted a microSD card into an SD card adapter, and then inserting the SD card adapter into the CF card adapter. The CF card adapter was an EyeFi adapter and the microSD was Sandisk. Seems like my camera is fried. So sad.

by

The manual says.. Remove and re-install the battery. This doesn't always work in my case.

by

I have the same issue, error 99 and have to power cycle off and on to do anything.

Only a problem with one of my lenses though, so not as bad as yours.

Said lens got barged into by another tourist while on holiday and I get the error only on f5.6 apeture. I'm going to teardown the lens one day to inspect.

Will post findings if I have anything to report.

by

Add a comment

3 Answers

Most Helpful Answer

I have the same issue, error 99 and have to power cycle off and on to do anything.

Only a problem with one of my lenses though, so not as bad as yours.

Said lens got barged into by another tourist while on holiday and I get the error only on f5.6 apeture. I'm going to teardown the lens one day to inspect.

Will post findings if I have anything to report.

Was this answer helpful?

Score 1
Add a comment

I had the same problem, especially when I use the flash. The problem in my case is that the camera got wet (just a sprinkle of rain while a Disney). Now every time the flash pops up, I get the error. My solution so far has been to use an external flash. Hope this helps

Was this answer helpful?

Score 0
Add a comment

It seems to be shutter unit fault.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kim will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 19

All Time: 554