Skip to main content

Repair guides and support for camcorders produced by Canon.

47 Questions View all

Why won't my Canon Camcorder E65A tape rewind or play?

My camcorder won't play tape or rewind tape at all. Everything seems to work but the tape doesn't move either direction. Is it possible that the small belt drive is broken?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

1 Answer

Chosen Solution

There are a few rubber parts in the tape transport in this camcorder camera that over time do need to be replaced.

You'll need to locate the service manual for it online some where to understand how to gain access to the belts and/or pinch rollers. You might be able to rejuvenate with a rubber using a good rubber cleaner. I've used this one with success: CAIG CaiKleen RBR RBR100L-25C Rubber Cleaner Rejuvenator. The service manual should supply a good parts breakdown if you need to order a new part from Canon.

I wet a Q-Tip (cotton swab) and rub it acres the rollers as needed and then wipe off any excess. For belts if I can get them out I wet a paper towel and drag the belt across a few times. The trick here is not to get any of the cleaner into the mechanism as it can make things worse!

Was this answer helpful?

Score 2
Add a comment

Add your answer

Bob will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 6

All Time: 683