The Samsung Galaxy S3 is a multi-touch, slate-format smartphone with eye-tracking ability, increased storage, and a wireless charging option.

566 Questions View all

Accelerometer and Magnetic Sensors stoped working

Hello Everyone,

I have a Samsung Galaxy S3 (i9300) and after the phone being updated and then rooted, the phone started having problems.

Those problems are with the Accelerometer and the Magnetic Sensors both stop working.

I've looked at the Secret Menu from Samsung (*#0*#) and try them but they are stuck on 0 value.

What bothers me is that, if I'm not mistaken, the Accelerometer and the Gyroscope sensor are the same chip, but the Gyroscope is working and not the accelerometer (the phone just won't rotate).

Idem with the compass, if I use any application on the Play Store for testing the compass it simply don't move. But then, if I open Google Maps and click on street view it doesn't move as well (disabling or enabling the compass mode doesn't solve it), but if I click 3-4 times on the button the screen divide in two and I can use a very badly calibrated compass (I think that it is using the compass at this point).

I've tried :

- Installing 2 different Samsung Stock ROM from 2 different regions.

- Installing CyanogenMod CM10.2 stable and CM11 Nightly

- Installing Ubuntu Touch

Nothing solved, this is why I am starting to think that it is an hardware issue.

Any help would be appreciated.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

If you have a rooted device try install nameless rom. this is the only rom that makes my screen rotate

Was this answer helpful?

Score 1
Add a comment

Exactly the same problem.

Have you discovered what the problem ? soft or hard ?

Thanks

Was this answer helpful?

Score 0

Comments:

Dear Marcos Fernandez,

Yes I have discovered the problem, and it is hardware. The connection between the chips is damaged (for un unkown reason, but since it wasn't my phone in the first place it can be water damage). This "problem" is also the cause of the camera not working.

As for the repair, if you are interested. I didn't find either a simple way to solve it nor a enterprise willing to do it at a reasonable price (it was always over 150€ which is the actual price of the phone here in Portugal).

My solution was to buy a new motherboard in aliexpress, it cost me 60€ (aproximatively already with shipping fees), but at least I had :

- 1x New motherboard working :)

- 1x Old motherboard working at 95% which I can use to get components if anything stops working on the other board.

Sorry for not proposing a "miracle solution" but at least it works.

Best Regards,

Luis Da Costa

by

Add a comment

Add your answer

Luis Manuel Ramos Da Costa will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 17

Past 30 Days: 93

All Time: 4,302