Model A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5 or 3.4 GHz Core i7 Processor

318 Questions View all

bad earphones input and ethernet.

Hi, I cheked a lot of times with different earphones and the same thing: when I plug the earphones I hear weird sounds and only in 1 ear.

The speaker is just fine, so does the earphones - it's a problem in the input.

I also got a problem with the ethernet input - I used the ethernet cable using my lapop and everything works, but when I connect it to the iMac it doesn't work.

All the other connectors are working (I have no idea about the FireWire)

Also when I first bought the iMac I used ethernet and also the earphones input and they both worked well.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Need more info than a generic ID that covers 19 models over 5 years.

by

iMac mid 2011 EMC 2429

by

Add a comment

1 Answer

Chosen Solution

Of course the earphones work as expected in other devices?

If the cable end is still good (tang there and not weak) it may be the port is damaged. Generally these ports are not designed to be used often so frequent and rough handling may damage them.

Logic board soldering takes lots of practice and requires special tools. A local computer repair shop, or small electronics repair shop should be able to repair them if (after you examine them) they seem lose (there should be no movement of the port/connector).

A workaround for each may be dongles. USB Ethernet and audio adapters could substitute for dismantling and repair of the logic board.

If this answer is acceptable please remember to return and mark it accepted.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ishay Frenkel will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 61