Repair guides and support for the autonomous Roomba vacuum cleaning robots by iRobot.

104 Questions View all

Resistance in right wheel/"error 5"

I've been getting the "Error 5 right" message on my Roomba 650. The right wheel seems to have twice the resistance of the left wheel. I took out the wheel module, opened it up and cleaned everything out. The problem persisted so I ordered a new wheel module. Still no luck. Then I noticed something very odd: the wheel has normal resistance when it's out of the Roomba but as soon as I lower it into place the resistance immediately doubles. Even with the battery removed this happens. I've very meticulously cleaned out the wheel well and it makes no difference. I've also cleaned the optical sensors and tried doing the Spot/Dock reset. Nothing. Any ideas??

Answer this question I have this problem too

Is this a good question?

Score 2


I have the same exact problem


I also have this problem- did you ever figure it out?


Any of you guys had any luck? I have the exact same problem


I called them about it and they said I need a new robot. They will sell you just the robot part for $199 and you use your own charger & battery and maybe a couple of the other parts


I had same problem and ordered a new wheel - still same problem. they offered to sell me the core unit for 20% off - which they said would cost around $330. I declined and returning part. We haven't used it on a daily bases so would have thought it would last longer than a year or so. :-(


Show 2 more comments

Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

2 Answers

Most Helpful Answer

This is what is known as an H-Bridge driver circuit problem. It is an issue on the main circuit board. It can be fixed but only by somebody with advanced circuit repair knowledge. Replacement of the main circuit board is what I do to fix them. While relatively complex, it isn’t outside the realm of a reasonably competent DIYer. Of you can send your bot to a robot repair company. Boards are available on EBay.

Was this answer helpful?

Score 1
Add a comment

I believe it is a loose connection of solder point near the plug. I used electric cleaner from radio shack and it worked again for a few seconds and then stopped. Need to figure out how to get into this area of the Roomba. Watching Youtube for the answer. Looks like the area is plastic welded shut. Either way I'll get inside for a visual inspection.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Chris will be eternally grateful.
View Statistics:

Past 24 Hours: 6

Past 7 Days: 49

Past 30 Days: 224

All Time: 3,131