Bad disk controller bad or Hard Drive Cable?

2 Different hard drives refuse to partition with disk utility while being connected internally to this mac book pro. The drives work fine in other machines. I pulled the original drive verified it with disk utility, copied the data off and ran the extended manufactures test tools on in which said it was ok.

So I figure either the hard drive cable or the disk controller on the motherboard is bad. Is there a way to tell with out buying another cable?

In other cases I read about where the cable was bad the disks were not showing up at all. In this laptop they show up in disk utility but writing (including partitioning) doesn't seem to work. The laptop boots fine off things connected to usb.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Can you give us the make & model of the HD's you tried.

by

Also, I've tried with the original internal drive: Seagate ST9250315ASG (250GIG)

and the drive: hitachi 5K250-160

both are apple branded as well.

by

RCWelsh - You really need to post your own question with your systems details.

by

Add a comment

1 Answer

Chosen Solution

Yes, Apple had a bad run of SATA cables so it's possible the problem is the SATA cable. But before we go down that path lets make sure your systems EFI is up to date. Review this Apple TN: EFI and SMC firmware updates for Intel-based Macs. Also don't forget to tell us what make & model of HD's you have here.

Was this answer helpful?

Score 2

Comments:

Turned out to be the internal hard drive cable. Couldn't figure out a way to know without trying a working cable. Pulled one from a working mac book pro 2009, worked like a charm.

by

Add a comment

Add your answer

hudlee will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 15

Past 30 Days: 50

All Time: 2,401