Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

271 Questions View all

Headphone jack not working, I just hear a strange noise

A few seconds after I plug headphones, the left side warms up. I am musician and i have this problem since I plugged a guitar pedal into that jack. The internal speakers and the input jack work fine, the problem is just with the headphones output.

I looked in internet to replace the sound board but i can't find the specific part or the manual to fix it. I would be very thankful to receive help with that issue. THANK YOU

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Ouch! Sounds like you did some damage here ;-{

You could first try replacing the audio port assembly in case you damaged it. Here's the IFIXIT guide to get to it: iMac Intel 21.5" EMC 2428 Audio Ports Replacement.

Sadly, I don't think thats going to fix your problem as the guitar pedal likely zapped the circuitry on the main logic board. But here's hoping!

Was this answer helpful?

Score 1

Comments:

Thank you .. I will try to do that ..

by

Do you know where can I by the audio ports ?

by

The Apple part number is: Cable, Audio 922-9801. If that doesn't fix it your audio DAC circuit is damaged on the logic board. Search the part number on Google to find a supplier near you.

by

Add a comment

Add your answer

Evan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 12

All Time: 505