Can't get my discs out of the turntable

When the power switch is depressed, the digital screen lights up but no other button responds when depressed.

It has been taken to an electronics place twice.

When it gets to the shop, it works fine.

Help!!!

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

I don't know what more I can tell you. The unit I have is a DC-D2831. There are 3 CDs in the disc tray. I cannot get them out. When I turn on the power, the screen lights up with the time but I cannot change the time, nor can I get the CD button to work so I can't get at my CDs.

by

How do I unarchive my question?

by

Still hoping to get a response to my question about retrieving my cd's from my disc player.

by

Mine doesn't want to open up the cd tray too often either. It seems like something is sticking inside but sometimes if I lift the tray with my fingernail after pressing the open/close button, it will work. It's very touchy and for some reason the disc in disc 1 doesn't play at all or only part way before getting stuck like a record would.

by

Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

3 Answers

Most Helpful Answer

Check the outlet (try a different one) you're using at home. If you have a UPS (universal power supply) for your computer try plugging in to that. Ensure the power cord is fully and completely connected at home.

A voltage problem seems to be most likely if all you have to do to get it work is plug it in someplace else.

If this answer is acceptable please remember to return and mark it.

Was this answer helpful?

Score 1

Comments:

Plugging it into a different outlet hasn't worked. No UPS on my computer.

by

Add a comment

I don't have this exact player, I have the D2930 model which is the exact same one as in the picture, so apologies if this is incorrect. I have had quite a few problems (including this one) with it in all areas, and while I haven't exactly fixed this problem, I kind of know what's wrong and am able to get my CD's out of the player, albeit sometimes with a great deal of effort. I'm not sure if what happens to me is the exact same as what others get, but it seems quite similar.

Basically, around a third of all times that the CD I'm listening to finishes playing and skips to the next CD tray slot, it makes a slight buzzing sound and a few seconds after, stops. All of the buttons and functions of the whole player become completely unresponsive except for the power button and the disc eject button, which, whenever I try to press it, it makes the buzzing noise again and does the same thing, as if it's trying to come out but for some reason won't. The buzzing noise stops after about 10 seconds. This just endlessly repeats whenever I press the disc eject button, and all the power button does is turn the lights off and when I turn it back on I get the exact same issue. After being very frustrated for a while after this first happened to me, I had no idea what to do, but then realised that you have to try and pull it out yourself. But it's not just pulling it that you have to do, because simply pulling it out towards you doesn't exactly do it. You have to kind of jiggle the tray around as best you can until the tray kind of jumps or "clicks" into place with something, and this can be audibly heard and you can feel the tray do this when it happens. The tray then opens and I am able to take out my CDs.

I assume that this happens because something is faulty within the motor or whatever or simply wears easily (it is quite an old machine, though) and the mechanism which pushes the tray out does not exactly function properly. Watch out, though, because sometimes it can take a while for the tray to jump into place, and I remember having spent around 20 minutes one time repeatedly pressing the eject button and clawing my fingernails at the tray desperately trying to make it jump into place. Note that it's quite hard to move the tray around since there isn't really any part of the tray that sticks out which can be pulled/moved around, so a lot of the time I use my keys or something thin and long which I slip underneath the tray into the slight gap on the bottom and jiggle it around until it works.

This happens when the player is finished playing the current disc and then skips to the next one, and it does everything described. The other time that it occurs is simply when I insert a disc and press the button to close it, and once it closes it does the same. In that circumstance, it occurs on a little bit less than a 50/50 basis. You need to watch out for the buzzing noise, I'm not sure if this is the problem you experience and maybe it doesn't make the noise, but that's what happens with me. I've noticed that the problem usually occurs most frequently when it's skipping to the Disc 2 slot, so I've avoided putting my discs in the Disc 3 slot (because then the player will skip to Disc 2), but it can occur with the other disc slots. I've also just tried ejecting my CD once it's finished but before the player gets the chance to automatically skip.

It's not exactly a fix, and I imagine that you would have to dismantle the tray mechanism and change/repair the motor or whatever to actually fix it. I hope that this helps; again, if this isn't your problem or isn't the same machine model then I've really wasted my time, welp.

Also sorry for the incredibly long answer post, just wanted to give as much detail as possible.

Was this answer helpful?

Score 1
Add a comment

The DC-D2831 and the DC-D2930 are very similar models. The problem of the disc draw not opening is often caused by the disc draw being stiff in its travel, compounded by a stretched disc draw loading belt.

The problem is also compounded by cold temperatures making the problem more noticeable during the winter months. The turntable can be removed by the removal of the top side screws and then unplugging of the motor/audio plug. This will give you access to some of your discs. The cure is more involved and if you feel this is outside you field of expertise then it is advisable to take the unit to be looked at by a serviceman (that's if you can find one in this day and age). However if you are feeling self confident then continue.

Remove the two side panels. Remove the two ribbon cable plugs either side of the cd mechanism.

The cd mechanism is fixed to the baseboard by several screws on the bottom of the unit, remove these taking note of which screw goes where. Remove the two screws holding the front of unit to the base board. Carefully ease the front section forward along with the cd mechanism as far as existing cables will permit. The release gear for the disc draw is on the underside and towards the front of the cd mechanism .

Rotating this gear will open the disc draw and you can now remove the disc draw front trim (this is clipped in place and is a real pain to remove). You can now lift the front unit out enough to remove the cd mechanism. Remove the disc draw loading belt and slide the disc draw out manually. Clean the disc draw runners and the laser assembly lifting plates. A thin application of a suitable grease will help. Having done this slide the disc draw in and out manually, feeling for a smooth action with no binding or sticking of the draw. Do not slide the disc tray fully in or it will lock into position and you will have to rotate the draw release gear again to open it. When satisfied that the draw has free and easy movement then replace the loading belt with a new belt. Reassemble the unit in reverse order but do not refit the turntable or the disc draw front trim at this stage.

Plug the unit in and observe the action of the cd mechanism, the turntable will rotate and unit checks for presence of discs. Press the disc draw open button, dose the draw open smoothly if so then unplug the power cord to the unit while the disc draw is in the open position and refit the front disc door trim. Refit the turntable and check all the functions of the unit. If all is good then give yourself a pat on the back for a job well done.

best regards from Vintie

Was this answer helpful?

Score 0
Add a comment

Add your answer

Joyce will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 6

Past 30 Days: 20

All Time: 445