Problem replacing Hitachi 250G HDD with Sandisk 250G X210 SSD

I followed the ifixit instructions to replace my hard drive with the SSD mentioned above. the physical replacement was simple. I used super duper (which I have used extensively) to clone the HDD prior to the replacement. I tested the SSD by booting the computer from it using a USB enclosure - all seemed to work fine except it was a little slow - I attributed that to the USB connection. When I physically swapped the drives and booted from the SSD it was incredibly slow (virtually unusable). Do I need a different cable since I am swapping to a SSD? Any other ideas on why the performance is so bad. the reason I was making the change was to improve the response time but it got worse. Thanks for any help

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

You may have a SATA I/O speed issue here.

First I would check the systems EFI firmware. Review this Apple TN: EFI & SMC firmware updates for Intel-based Macs. You may also need to update the Sandisk drives firmware as well here make sure you use the USB external case for that.

Was this answer helpful?

Score 1

Comments:

EFI and SMC firmware up to date per apple website. Not sure what to do with SATA I/O issue if there is one - I am not all that technical.

by

See if this helps explain things Firmware Updater

by

Add a comment

Add your answer

craiglewis0203 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 345