Not powering on. Tried known good AC adapter. Light on the adapter.

I replaced the DC jack but still not powering on.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Why did you replace the original? Liquid spill? Fall/drop? - battery not charging?

by

liquid spill. Unknown what type of liquid. No visible corrosion on logic board or DC jack.

by

Add a comment

1 Answer

Chosen Solution

Aside from corrosion (check both sides) you must look for burn marks and swollen components. Use a magnifier. You could try using the jumpers to boot if you have a known good, charged, battery. You could try putting the battery in MacBook Unibody Model A1278

2 GHz (A1278) or 2.4 GHz (A1278) - uses the same battery.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

I looked very closely for burn or corrosion marks but could not find any. The customer decided to buy a new computer instead of wasting more time and money on it. Thank you all for your suggestions.

by

Add a comment

Add your answer

dkillian will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 136