Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

399 Questions View all

Unable to upgrade to 8gb RAM

I have an MBP 5,1 2.8 Ghz Intel Core 2 Duo running Mavericks and just tried to upgrade from 4gb to 8gb RAM. It hangs at reboot with both 4gb chips inserted, but will work with one 4gb (verified both) and a 2gb for a total of 6gb. I have found articles that upgrading firmware to MBP51.007E.B05 allows upgrading to 8gb. I am above that at B06 and no luck. Memory is DDR3 1066Mhz 4gb SODIMM PC3-8500. Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

You could have a few possible problems here.

To start with lets make sure your EFI firmware is the latest. Follow this Apple TN EFI & SMC firmware updates for Intel-based Macs to check and update your firmware, then try again.

If you are still having problems you should return the memory as it is not compatible. When you mix the modules the slower speed module speed is used. In this case your older 2GB module, which is why a 6GB setup works.

Was this answer helpful?

Score 1

Comments:

Hi Dan, Thanks for the reply. I verified I am at the latest firmware, and you confirm that 8gb should work. So I'll send the memory back and buy a name brand. All the best.

by

If this answer answered your question please remember to rate (score) and mark it accepted.

by

I'll do that now Dan. I've ordered Kingston memory for Apple and should know if that works in a couple of days. I had just assumed since the 4gb modules worked in combination with a 2gb, then they were good. We shall see. Thanks again.

by

Add a comment

Add your answer

Jerry will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 529