Model A1200 with 2.16 or 2.33 GHz Core 2 Duo processor

130 Questions View all

GPU install screw holes not aligned

Finished steps to remove GPU assembly per repair guide. Tried to install replacement GPU assembly and the holes on the GPU board do not align with the holes on the logic board, they are slightly off, the screw will not be able to go in perpendicular. I confirmed I'm putting the GPU pins into the upper half of the black receptacle on the logic board, the u-shaped divider channel looks aligned, I'm putting what I think is adequate pressure. Comparing what I see versus the repair guide photo, mine seems like the GPU assembly is not as far in as the photos. I move the replacement assembly aside, and tried to put the original assembly in, and it also doesn't align with the holes. So I must be doing something wrong, I just can't figure out what I'm doing wrong. The hole at the heat sink aligns ok.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

I finally got it. I was not tilting the card at the correct angle during the insertion. Once I got the angle correct, it worked per repair guide. iMac boots up fine with video, but then even before my Mac OS X install completes the screen goes black - but that's a different issue, different thread.

Was this answer helpful?

Score 0
Add a comment

Add your answer

rgpphelps will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 167