MacBook Pro 15" Unibody Early 2011 Repair

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

257 Questions View all

Mac cannot find new internal HDD I have installed

I have seen this question asked before, but always for different computers or with fixes that have not worked for me. I feel as if there is something very simple I am missing, so here goes:

I have just replaced my HDD with a Seagate 500 gb HDD. I originally replaced it it with a WD 1 TB HDD and got the same problem of the blinking folder with a ? mark on startup, and when inquiring their help line i was told that my computer couldn't support 1 TB, but 500 should be fine because my mac already had an HDD with 750 GB.

I was using OSX Lion, but do not have my install disk anymore, so I installed a patch to use recovery mode, however when I try to reinstall OSX via internet recovery with my new internal HD installed, it does not detect any drive present. The Install OSX section is just blank. I do not think any hardware was damaged during the swap, because when i use my old HD the computer still boots up normally.

i'm unfamiliar with lots of tech language, but maybe the problem has to do with my computer not handling 6 gb SATA? i am currently downloading any software updates i have not already in the hopes that it will detect my hard drive, but any help would be greatly appreciated. thankyou!!!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

It appears you been given a bit of a run around.

To start with Mac OS-X has no limits that you're likely to hit here with HD or Volume size limits (unlike a different major OS) Here's Apples own TN on it Mac OS Extended format (HFS Plus) volume and file limits. So you could put into your system a 2TB HD if it would fit. The person you spoke to was likely thinking the 1TB drive exceeded the height limits you have 9.5mm.

If you have correctly identified your system here you have a 15" MacBook Pro early 2011. Then your system has a SATA III HD connection, as such you should not have any issues with SATA I/O speed mis-match between a newer HD (SATA III) and your system.

OK lets move on the the meat & potatoes of your problem.

Put your old HD back in and then down load from the Apple Apps Store (if you haven't already) the Lion or Mountain Lion OS installer {ML is not free but worth getting} forget the recovery angle.

Now you'll also need to get a USB thumb drive 32 or 64GB in size to prep as a bootable disk using the installer (Lion or Mountain Lion). Once you have gotten the OS installed go to your prefs settings and select it as the startup disk. Restart your system making sure the USB drive is booting up (it will be slow so give it plenty of time). At that point your set for the last step here. Copy over the OS installer to the USB drive and then shut down your system putting in your new HD in.

After putting everything back together plug in the USB drive and restart your system. Again, give it some time here to boot up. Launch the installer app and partition & format your new HD and install your OS. Once your set go back into preferences and alter the startup disk again back to your internal HD and restart. You should be working at this point.

Was this answer helpful?

Score 1
Add a comment

Add your answer

jordan smith will be eternally grateful.

View Statistics:

Past 24 Hours: 4

Past 7 Days: 23

Past 30 Days: 59

All Time: 1,381