Skip to main content

iPod Classic 6th Generation. Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

906 Questions View all

How can I get my iPod Classic to Restore? Nothing works!

When I plugged my iPod into the computer this week, iTunes tells me it is corrupted and needs to be restored. When I attempt to restore it, it tells me that it can't be restored and gives me error code "1439." I have installed the newest iTunes and have repeated this process many times. I have tried different USB ports and cords. I have a PC (with Windows Vista) and when I put my iPod in "disc mode" and went to it's properties, it also will not restore. Help!

Answer this question I have this problem too

Is this a good question?

Score 10

What properties did it show you when you were in disk mode?


I tried the solution below with no success. When I am in Disk Mode on computer (Computer>(My iPod)>Properties), It says that I have 148 GB (out of 160) available, but the pie charts say that I have 0 Bytes used and 0 Bytes free? Extremely odd! When I try to error check, it says that Windows cannot access the disk


your hard drive is dead.


Hello I have tried to restore my ipod classic but itunes keeps indicating that my ipod is corrupt


Add a comment

2 Answers

Most Helpful Answer

Mikayla try this from Apple. It is the same for error 50 but could work for 1439 as well:"

Disconnect the iPod from the computer and close iTunes.

Highlight all of the following 10 lines of text that begin with regsvr32 and then choose Copy from the Edit menu of your web browser:

regsvr32 /s softpub.dll

regsvr32 /s wintrust.dll

regsvr32 /s dssenh.dll

regsvr32 /s rsaenh.dll

regsvr32 /s gpkcsp.dll

regsvr32 /s sccbase.dll

regsvr32 /s slbcsp.dll

regsvr32 /s mssip32.dll

regsvr32 /s cryptdlg.dll

regsvr32 /s initpki.dll

Open the Notepad program by navigating to:

Start > All Programs > Accessories > Notepad

In Notepad, choose Paste from the Edit menu. Note: Make sure that the text that appears in Notepad is the same as what is shown above.

From the File menu, choose Save As.

For File name, type appleipod.bat and save the file to the Desktop.

Close Notepad and locate the appleipod.bat file. It should appear on the Desktop

Double-click the file and you will see a black window appear on the screen for about a minute. Wait until the window automatically disappears and proceed to the next step.

The appleipod.bat file can be deleted at this time.

Open iTunes and connect the iPod.

When the iPod appears in iTunes, restore the iPod and resync your content.

Note: Because some malware may unregister the .dll files, make sure you have the most recent updates to your anti-virus software and then do a full scan of your files.


If the above does not work and you get the "It says that I have 148 GB (out of 160) available, but the pie charts say that I have 0 Bytes used and 0 Bytes free" sounds like you have either a bad hard drive or a bad hard drive cable. I would check the hard drive with a Zif-to USB connector.

Was this answer helpful?

Score 9


Thank you so much! Had tried just about everything to no avail. This finally worked!


This absolutely brilliant, clear concise and effective. I ve been all over the web this is the only thing that worked!!!


still didnt worked fuh me and i did everything step by step


Amazing answer. I tried everything and only this worked, i was having the same problem with my ipod, also showing it as 148 gb when it is in fact160 gb and was unable to restore it until I tried this. THANK YOU SOOOOO MUCH!


I tried everything I could find and this was the only thing that fixed my iPod classic! Thank you!


Show 10 more comments

Add a comment

I feel your frustration, had same situation with iTunes.

After very long hours of trying everything short of reinstalling Windows, I found a solution that worked for me:

replaced softpub.dll in both System32 AND SysWOW64. Et voila! Done.

I'm assuming this is valid for all things Apple, as I have seen literally hundreds of posts. Hope this also solves your predicament.

Was this answer helpful?

Score 1


Replaced them with what?


Use EaseUS Partition Master Home Edition (Free) and format as FAT32 with 128k clusters. After this restore works well.


@setfreen This worked like a charm. Thanks.


Add a comment

Add your answer

Mikayla will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 8

Past 30 Days: 39

All Time: 38,594