The MacBook family was first introduced in May 2006 and replaced the iBook as Apple's consumer laptop.

3684 Questions View all

unable to create fusion drive with SSD and HDD

Hi:

I have a late 2008 macbook (2.4 GHz), in which I replaced the optical drive with the hybrid 500 g HDD and added the Samsung 840 series SSD (240 g) in the original HDD slot. I am running OS X 10.7.5 on the macbook.

The system shows two drives, but no matter what I try, I am not able to create the fusion drive. I tried booting the system using Command - R (since my boot drive is SSD) and tried the following command in Terminal:

diskutil cs create newdrive disk# (SSD identifier) disk# (HDD identifier)

Every time I try this command, it says the CoreStorage operation started, and then it gives the error "Invalid Request".

Also, "diskutil cs list" command shows that I don't have a corestorage volume on my system.

I tried formatting the hybrid HDD and then tried the fusion, same result. I tried installing the OS on the HDD and then tried fusion, same result.

Any help will be greatly appreciated.

~ paresh

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Paresh -

To start with you have a hybrid drive which may not be compatible working as part of a Fusion Drive. I would first try setting this up with your older HD instead to see if that is the problem.

Here's a good write-up on how to setup the Fusion Drive with Mountain Lion which I would also recommend is what you should be running here. Other World Computing Blog - Fusion Drives on Non-Fusion Drive equipped Macs

Was this answer helpful?

Score 2
Add a comment

Add your answer

paresh1506 will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 4

Past 30 Days: 23

All Time: 2,133