No MagSafe light with battery connected

Bought this as a refurb thru Apple. My daughter thought her charger was no good about 6 months after we bought it, no light on MagSafe, was not charging. Tried a friends charger still nothing. Went to Genius Bar, hers worked at the store of course. A few months later she spilled wine on her keyboard. I disassembled, thoroughly cleaned with rubbing alcohol, dried, reassemble, worked with no issues for 5 months. Last weekend no MagSafe light/battery not charging issue reappeared. Replaced I/O board, still nothing, reset SMC, still nothing. Opened back up, disconnected battery, attached MagSafe, light turns green and computer runs. Turned off, plugged battery back in, no light/not charging (laptop does run but battery only has 8% left). Now what?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I suspect your power control IC located on the back side of your main logic board has some corrosion or is bad. Look at Step 15 of the system teardown locate the TPS 51982 Chip.

Are you able to solder SMT components? If not you'll need a new logic board or will need to find someone with the correct tools and skills to replace this chip if it is bad.

Was this answer helpful?

Score 1

Comments:

I do have soldering tools, can I buy a replacement chip online?

by

Have you soldered SMT devices before? They require special tools and techniques to do it correctly. Yes, the part is available online. Think this thoroughly before you try as you can damage your board. First, see if it looks bad or has and spillage around it. Use some isopropyl alcohol to clean it.

by

Add a comment

Add your answer

Leslie will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 2

All Time: 618