Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

839 Questions View all

Problem with audio jack

Hi. I have an issue with my audio jack : I only hear audio out of one headphone and the hold button doesn't work. I bought a replacement audio jack, but there is exactly the same problem with the new one. I have to notice that there is no more black tab to hold the ribbon cable to the logic board, so maybe it's the problem...Any ideas to fix this ? Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

dustytill, if you are certain that your new cable is working, it is very likely that it is caused by the missing tab. Locking the cable with the tab down to the connector ensure that it makes proper contact. The missing tab prevents your cable from doing so. If you have a old board, you can try to replace the tab, but for that you need plenty of patience and a good magnifying source. You can try and see if a good clothes tape might apply enough downward pressure to allow the cable to make contact (do not use crazy glue or anything like that), otherwise you will need to replace the board. Hope this helps, good luck.

Was this answer helpful?

Score 2

Comments:

Hi. You were totally right ! The missing tab is actually important ! When I oush the ribbon cable on the logic board, all work perfectly ! The only question I have is what to do to push the ribbon cable enough without my hand ? Thanks

by

As I suggested in the original answer, try some clothes tape. Electric tape etc. will most likely not work.

by

Ok I fixed it in my own way.

by

Add a comment

Add your answer

dustytill will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 321