"Charging is not supported with this accessory"

Every time I plug in my iPod Touch 4th generation, a big yellow triangle with an exclamation point in it pops up, sometime after 5 seconds, sometimes 30 seconds, etc etc, with a message beneath it saying "charging is not supported with this accessory". Also, my computer is no longer recognizing my device. I have tried every solution I could find on the internet thus far: buying a new cable, charging on a docking system, cleaning the USB port and iPod port, even leaving the charger 20-25% sticking out of the USB port. Is there anything I can do to fix this without going to an Apple store??

Please help!!

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I have also tried putting the device in "airplane mode", turning the device off, plugging the device into my PC (which turns it back on), and then turning off airplane mode. This, too, didn't work.

by Kelly Jewell

my I pod is not recognizing the charging cable can you help?????

by magdelena

Add a comment

2 Answers

Chosen Solution

Kelly Jewell, this error is most often caused by a faulty dock connector. The first thing you want to try is to clean it with a toothbrush and some isopropyl alcohol. Clean it well. Use a few puffs of compressed air to blow out any pocket lint etc. If that does not resolve the issue, replace the dock connector. Of course, make sure that you also try a different cable.If nothing else will work, you may have to Reball/Replace PMIC. Anything after that could be turning into a board level repair, due to failed SMD component. Hope this helps, good luck.

Was this answer helpful?

Score 2
Add a comment

I'm 12

My iPod touch 4

Does the same can you give advice for a fellow noob ?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kelly Jewell will be eternally grateful.

View Statistics:

Past 24 Hours: 3

Past 7 Days: 49

Past 30 Days: 204

All Time: 12,463